I can only load google when comodo is installed

right, my problem is that when I have comodo installed the only page I can see (both in firefox and IE) is google and the results of the google search, all other pages do not load. How do I fix this?

Have you tried making FF or IE a web browser under the firewall settings. Comodo doesn’t have a web shield.

yes, I’ve even tried setting it as “trusted”, here are my settings:
http://img297.imageshack.us/img297/7733/comodoruleskc4.jpg

Why did you change you Comodo entry to “trusted”. Default from install is " outgoing only". Have you tried uninstalling Comodo completely using Revo uninstaller in advanced mode then reinstalling?. Like I said Comodo doesn’t have a web filter or shield and should never effect web page loading. All pages load for me under IE or FF. What av are you uisng? Did you block anything under D+?

[attachment deleted by admin]

the reason I added it to trusted was in hope that it would solve the problem, it didn’t. I followed your instructions- used revo uninstaller to uninstall and reinstall comodo, same thing. Even tried reinstalling outpost firewall just to delete it with rev uninstaller, btw using outpost firewall everything opens, anyhow I reinstalled it and deleted it with revo uninstaller, then reinstalled comodo, didn’t help.

Its not Comodo. When you used Revo in advanced mode and Comodo said reboot did you? Your not suppose to. At that point you click next on Revo and delete all registry and program entires then reboot. Something is D+ is being block when it should be allowed. Have you looked at your logs?

nope I didn’t reboot, same as with outpost firewall I continued the revo uninstall process. Checked the network events log and it was empty.

please help!

Haven’t seen this one before. Do things work normally without Comodo? If so, not a clue. Do you have any global rules? You can add a block and log all at the end of your application rules see if anything is being lost.
But a few general things to look at that could cause this:

  1. Check your HOSTS file (windows/system32/drivers/etc) to make sure there is not a wild card redirecting your http requests
  2. Change DNS servers to make sure yours isn’t poisoned-try 4.2.2.1
  3. Are you using a proxy? Either directly or via a virus scanner? Check your redirection settings. Also try an https access, and look at your IE internet settings.

thank you for your reply, yes, without comodo everything works fine. Your suggestions seem windows-specific.

I really liked the overall look of the firewall, too bad I won’t be able to use it because of this problem :frowning:

Look in your D+\Advanced\Computer Security Policy. See if anything is blocked. Put IE and FF as a web browser in the firewall. Have you tried D+ in training mode. Are you blocking shockwave? Comodo doesn’t have a web shield and should not interfere in any web page loading. I use Comodo on 2 pc’s and never once have I not been able to load a web page. Also look in your firewall settings for something you blocked. Put the firewall and D+ in training mode and launch FF or IE.