I can browse the internet, but I can't ping google or my router.

A few days ago, I was having problems with the internet because my cable modem kept on resetting. that since has stopped resetting. Then the next day, it would temporary drop me from the internet and now that seems to have stopped and ceased. I am able to browse the internet with any browser, whether it be Comodo Dragon, IE, Firefox, etc and I am connected to the internet, but when I tried to ping a site like google.com, the ping fails. I have allowed ping.exe in my firewall and it is not blocked. I closed the Comodo firewall and tried to ping again, but it still fails. It even failed when I tried to ping my router. Do you know if this might be an issue with the firewall or something else?

Can you tell us:

  1. What you have for your ping.exe rule
  2. What your Global firewall rules are
  3. What the ping error message is.
  1. Ping.exe rule was set to allow and remember answer
  2. Global firewall rules were alert me to incoming connections and stealth my ports on a case by case
  3. The ping error message in command prompt said request timed out and it stayed that way until I ended the ping.

Ping timed out errors are usually caused because the the client failed to receive a reply. This can be caused by a variety of reasons, but I’d start by doing the following

  1. ping localhost (127.0.0.1)
  2. ping another computer/device, other than the router, on your LAN
  3. make sure you’re not blocking Echo Request Out in Global rules.

Here are the results of what I did.

  1. The ping to localhost was successful.
  2. I attempted to ping my mom’s computer, but request timed out appeared
  3. I first set Echo request in global rules to allow because it was being blocked. I set the direction to in/out, nothing, I then set it to just out, nothing still, even when the global rule was set to allow.

Please post a screenshot of your global rules

I’m hitting print screen on my keyboard, but for some reason I can’t post the screenshot. What am I doing wrong?

you have to paste it into word or paint. Or you can try mwsnap its what i use. it lets you take screenshots of any rectangle area or window then it saves the file to any format you pick

thanks for the help.

[attachment deleted by admin]

There’s nothing wrong with those rules - you don’t need the allow rule - so something else is causing the failure. Are you using the host name or IP address in your ping?

For the router, I used the IP address. For the other, I used hostname