Hyper-V does not work with Comodo Firewall


first I am sorry for my English. I upgraded Comodo FW to latest version but when I launched Hyper-V it does not worked.
It says something like that: http://www.imagehosting.cz/?v=20170102.png

When I uninstall Comodo FW, Hyper-V works.

2: Windows 10 64b latest stable version 14393.576:
3: I wanted to launch Hyper-V:
[b]4: Ulož.to Disk
5: I want to use Hyper-V:


When you enabled enhanced protection mode in HIPS settings comodo then works as a type-1 hypervisor and thus another type-1 hyervisor such as Hyper-V will not work. So disable enhanced protection mode if you need to use Hyper-V.

OK but my PC will be more vulnerable or not? Sorry for my English.

If you are not running anything unknown then you should be fine, but if you want to have the highest security settings that comodo offers then leave it enabled. But like I said if you really want or need to use Hyper-V then you need to disable enhanced protection mode.

OK. I probably understand. I use Comodo sandbox very often. I use Hyper-V occasionally. So when I want use Hyper-V I will ENHANCED PROTECTION switch OFF.

But Comodo FW 8.x version worked with Hyper-V on windows 10 64b.

Or you can try adding these files to the exclusions of detect shellcode injections vmms.exe, mmc.exe, virtmgmt.msc, vsconfig.dll see if that helps.

Hyper-V works now even when I turned ENHANCED to ON. I think it is therefore when I uninstall Comodo and reinstall it again because when I install Comodo for the first time I had in Add/Remove Programs 2 part/thing from Comodo and when I uninstall and reinstall COmodo, there is only Comodo firewall. I do not know the name the second part of Comodo. But it was something like Comodo Internet Security. I hope you understand because it is too hard for me to translate it to English.

Ok glad it works now, maybe it was internet security essentials or secure shopping? Moving to resolved.

I am sorry but I cannot say it in EN correctly.

I did not install CIS, I installed only CF. But I noticed when CF is installed for the first time on PC there is Add/Remove Programs 2 parts from Comodo (one is Comodo Firewall and the second is something like Comodo Internet Security - but it has weird icon). When CF is uninstalled and reinstalled again 1 part is missing and it did not install it again. I do not know why. I think it is a bug.


I have similar problem.
I am using Visual Studio 2015 with Xamarin in order to create Android apps.

Before I upgrade to the latest Comodo Internet security I was able to run the Android emulator via Hyper-V without problem.

However now that I upgrade to the latest CIS I cannot run the emulator any more.
Now I get error: Could not launch ‘VS Emulator 5.7" Marshmallow (6.0.0) XHDPI Phone’ device. Exit code 10. which I find out that is caused by the Hyper-V not being able to start.

Then I unistalled the CIS and the emulator worked.

I installed CIS again and Hyper V stopped working again.

I tried disable the HIPS but Hyper-V is still not working.

I disable all the features of the CIS (Antivirous,Firewall,HIPS,…) but Hyper-V is still not working.

I terminate from the task manager the CIS but the Hyper-V is still not working.

See attachment for error.

I have:
Windows 10 64 bit,
Version of Microsoft XDE 10.0.10586.0

Any suggestions on how to precede?

Thank you