HTTPS is forced no matter what

I am using CID
I am trying to disable the HTTPS for Google as some tasks in Crowdflower will not validate that you visited a site when Google has https enabled. I am pushing the “Don’t Force HTTPS” button then I remove the HTTPS header, but it is still not going to normal HTTP.

Not Bug.
Type in the address bar: about:config
Change the setting (screenshot). true → false
Restart the browser.

[attachment deleted by admin]

set it to false and reset the browser, but it still did not work.
Normal Firefox does not enforce https right out of the box. Going to have to use that for tasks for now.

I’m sorry.
Maybe I did not understand what you to wanted. I thought you’d want to see headlines sites.


You can use the addon HTTPtoHTTPS to disable HTTPS for the Google website. Make sure the padlock in the address bar is grey and not green, then click on the blue S in the bottom right corner of the window to remove the S from HTTPS for the Google website.

Get it here: HTTPtoHTTPS – Get this Extension for 🦊 Firefox (en-US)

gs22: Tried that, but it still does not work. I make sure that when I click the padlock and click Don’t Force HTTPS that it is grayed out. Still does not do anything.
I have tried to manually remove the https:// “s” before, but that does do anything.

Also, I have had this same bug happen in Comodo Dragon.

donotbug, you are correct. This addon is no longer working for Google Search. It still works for Google Images Search, but it changes back to an encrypted session to list the search results and then the addon no longer works on the search results page. The addon still works for this forum, but that doesn’t help you any either. Sorry.

donotbug, I did a two minute Google search and one or more of the following addresses should load the Google search page without the HTTPS:


Hope that helps.

Update: Those three links above worked at the time of my original post, but now they no longer work. Google is quick to fix any efforts to undo https for their searches.

It’s weird; seems like Google is now forcing https. It is now forced on Firefox.

Although, doing tasks on Firefox is working even with https Google. I have not tried it yet on IceDragon.

Tried it on IceDragon and now the https Google is working just fine with Crowdflower tasks. It might have been something with yieldtrack since that is what tracks to see if you went to a certain website or not.