How to stop Windows from auto-enabling file and printer sharing?

In Windows 7, both 32-bit and 64-bit, I disabled file and printer sharing in this menu:
\Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings

I disabled for both home and public profiles, and on the admin and standard user accounts. The next day, I see that file and printer sharing has been automagically enabled on all accounts.

This is happening on two different PCs, and I’m sure they are clean of malware. Anybody else seeing this issue? How do I stop Windows from automagically reducing security like this?

There are some customized windows 7 out there that don’t save certian changes. Like if you disable some of the windows features, it’ll come right back. Usually ben rockers stuff, nlite vlite <—Ones that are customized by these seem to to that. I know because I tried a few of them

anyway, let’s assume that wasn’t the case, so let’s do this

  1. Click on “start”
  2. Go to “run”
  3. type in: services.msc
  4. look for Homegroup Listener, Homegroup Provider
  5. Double click on it and inside “startup” change it to disabled".
  6. Click on “Apply”
  7. Click on OK"
  8. Do the samething with the other one like in step 5

When your done, restart the computer :slight_smile:

Anybody else seeing this issue?
Yes, it does that to me

If you disable the Windows 7 firewall, file and printer sharing and network discovery are enabled. If you disable file and printer sharing and or network discovery, the firewall is enabled.

This is something I went through some time ago, apparently it’s by design…

How to disable firewall as well as file and printer sharing

Thanks Radaghast. I was also having a problem with the Windows Firewall automagically re-enabling. Now I understand why.

jay2007tech, I am using the standard retail installation of Windows 7 Professional. Thanks for the tips on which services to disable. Disabling them prevented svchost.exe from sending UDP from/to port 3702, which I was seeing in my firewall logs.

If I use the Windows Firewall instead of the Comodo Firewall, then I won’t experience this Windows 7 bug.

A couple of things to think about.

UDP Port 3702 is part of the Network Discovery process, which is not specific to Homegroups. So, disabling the two Homegroup services, won’t have much effect on the Network Discovery. The Network Discovery process also has dependencies on a number of other services, such as SSDP, UPnP, FDRP and DNS. It also opens ports under the System process and operates over both IPv4 and IPv6.

Speaking of IPv6, Winodws 7 enables IPv6 by default, it’s a requirement for Homegroups and also opens a number of ports under the svchost context, as well as other system process and applications. If you’re serious about locking down the OS processes, you need to this this into consideration.

Finally, about the only reason I don’t use the Windows 7 firewall, is simply that it can’t be protected. Unlike other third party firewalls, which can utilise password protection to prevent tampering and disablement, Windows 7 firewall has no such capability, unless you consider the ‘Protect all network connections’ option that may be configured via Local computer/Group policy (only available on some versions of Windows 7).