How to stop endless signature install which is taking all cpu?

For the last few months, every few days, always a middle-of-the-day (UK time) check for updates, the updater gets stuck at the ‘Task: install Updates Status: Activating the new updates’ point. When this happens, it just goes on and one, 1 hour, five hours, seven hours … and the cavwp.exe process grabs all available cpu snd just runs it and runs it and runs it.

i have the updater checking every 6 hours per the default, and all the other updates at other times of the day are always fine, over quickly, but this every few days, this middle day update fail keeps on happening, jamming up the cpu.

I’m not writing because I want a fix (although that would be nice) but because I want to know how to stop it when it happens! Almost nothing works. Clicking the Stop button in the Comodo Task Manager just causes the status to change to ‘Terminating’ but it doesn’t terminate, just goes on and on. Using the Windows (Windows 7) Task manager to try to end the cavwp,exe process just gets ‘Access denied’, trying to End/Kill/Terminate with Killswitch also access denied, and ‘suspend’ has no effect. Quiting the Comodo Desktop program does nothing, and it’s still reporting the same in the Comodo Task Manager if I then restart the Comodo program. Sometimes with repeated attempts at closing, killing etc for many minutes, but in an order I can’t then remember, I have got it to stop, but mostly the only way is to restart the computer. Either way it is always fine and does a quick, successful update after one of these episodes. But it is often not convenient to restart the computer, so, please, HOW CAN I STOP cavwp.exe when it gets stuck and goes nuts like this? Surely there is a way? Surely Comodo has some means to force an abort of one of its processes that’s gone nuts?

You can use CIS Task Manager to stop the update process. You can add the shortcut to CIS Task Manager to the widget if you like. Another strategy would be to limit the update frequency to daily or update manually.

Good news is that the av update process for the upcoming v8.2 is much lighter. It is very much noticeable on the old netbook on which I am currently working. There is a beta release of v8.2 in case you got curious.

Sorry, didn’t get a notification there’s been a reply.

Am back again because it’s happened again. The update is jammed up on ‘Installing the signatures’ ’
Applying the update’ again, like the other times. It’s been supposedly updating, and hogging most of my cpu, for the last 4 hours and 52 minutes, status ‘running’, 16.67 percent.

And, no, I can’t stop it with the CIS Task Manager. As I said in the original post, if I try, the only thing that happens is that the status in the CIS Task Manager changes to ‘Terminating’ but it doesn’t terminate, just goes on and on and on clogging up the cpu. From the times when I’ve spent half-an-hour trying to stop it one way or the other and it has eventually stopped (which it often doesn’t) it’s possible that it was the CIS Task manager Terminate that did actually stop it (by the time it has, I’ve repeatedly tried so many things I have no clue what eventually did it), but if it is, then it takes about half-an-hour to do it.

I’m just … I can’t go on with it running out of control and blocking up the cpu for hours and hours like this. There HAS to be some way to kill it when the updater goes rogue - surely? Otherwise … I don’t want to move to another antivirus program, but I may have to. When’s 8.2 coming out of beta? I used to beta test a number of programs, both public and private betas: but I’ve had to give that up since becoming disabled. Can’t cope anymore with stuff I’d once have been happily diagnosing, nailing down and finding workarounds.

Please - there must be some way to kill the updater … doing something running as the administrator or something.


While I can’t stop it from the Windows Task Manager or the CIS Task Manager, and in Killswitch ‘Kill’ says access denied and ‘Force Terminate’ has no effect, ‘Terminate and Reverse’ DOES work and kills cavwp.exe. Hadn’t tried that before as I wasn’t clear what it did. Still not clear, but it works, which is all that matters. And CIS will then do an update in a quick and timely fashion, as on p[previous occasions.

This runaway cavwp.exe every few days is … annoying. But now I’ve got a way to stop it i can live with it for now.

Maybe it is a matter of Windows, but under Windows XP there are 2 processes cavwp.exe running during update.
First cavwp.exe uses only few CPU and RAM.
And the second cavwp.exe process, which is responsible for update, uses a lot of CPU and RAM. And I can kill/terminate this process with every program, which allows to kill/terminate a process .

Try disabling automatic updating of the AV and do it manually. That way you will have the control. :-La