How to stop Comodo from intercepting URL's?

If I type a wrong URL, I want to get the old 404 error back, not get some useless intercept like the one below that doesn’t tell me anything.


The URL is not valid. Did you mean

Is there a way to disable this useless functionality?

You’re probably using Secure DNS - Comodo there are instructions on the left side of the link for changing these settings. If you’re using Dragon, you can change the settings for that browser in:

Settings/Under the Hood/ Enable malware domain filtering (Comodo Secure DNS)

I had switched to Level 3 and got rid of the Comodo Secure DNS because of this. But I have two network ports on this mobo and recently switched from port one to two when I was shooting a problem. I didn’t check the DNS settings. Did so just now and found that yes, it was set to the Comodo settings. I changed it to Level 3 and now all is back to normal.