How to open ports for mesenger and google talk

hello everbody I am facing problem using messenger and google talk as i cannot perform file sharing and some application sharing with these two programs.

as incoming ports are assigned dynamically to them so opening few ports in firewall resulted in temporary solution.

one solution that appears to me is to allow all incoming connection request in global rules then use application rules to decide which application is allowed to recieve incoming connection request.

but this sounds odd

in my computer alpplication layer gateway is always in listening mode but i had permitted svchost only outgoing connection attempt

I have gone through MS article which states as follows

To enable voice and video communications with Windows Messenger through a non-UPnP firewall, configure the firewall to allow incoming traffic on UDP ports 5004 – 65535.

For other purposes, enable the following ports:

File Transfer: 6891 (to allow 10 simultaneous file transfers, open ports 6891–6900)

Application and Whiteboard Sharing: 1503

Remote Assistance: 3389

does this mean I have to open ports manually in global rules as under application control rules for windows messenger allow Ip in/out any any is not giving the desired result

is it possible to turnoff comodo firewall and continue to use D+ feature with windows frewall

a) Firewall tab → Common Tasks → Stealth Ports Wizard → Alert me to incoming connections…
b) Use the predefined firewall policy ‘Trusted Application’ for both messenger and google talk
c) Your router may or may not need to be configured - Port Forwarding Your Router to Get Open Ports

Try putting the firewall and D+ in training mode.

yes it is working now thanks every body.

but i feel Online HELP manual of COMODO V3 should be corrected
It says like, for outbound connection the application rules are consulted first.
whereas for incoming connection first GLOBAL rules are consulted then appilaction rules are consulted.

It is not true
Global rules in my present condition are

allow Ip out any any any any
allow ICMP any any any
Block IP in any any any any

whereas all application rules have this format

Allow TCP/UDP out any any any any
Block ip any any any any

Except for svchost port 135,137 138, 139 ,445,500,1900,2000,4500 are blocked

coming to real point

i didnot modified the global rules but added windows messenger to trusted application list ,application network acess rules were created automatically for msmsgs.exe

No change occured in GLOBAL RULES, yet i was able to recieve incoming connections and use messenger sucessfully

it implies that even in incoming connection first application rules are consulted then global rules are .

It appears that global rules are similar to opening a specific port in inbuilt windows Firewall.

I am not a expert but appears comodo firewall is using windows firewall service and using hooks b/w ipnat.sys and tcpip.sys
thats why global rules as stated in help manual are not working

But adding a application to trusted application list is creating an exception similar to in windows firwall and things are working.

I think correction should be made in HELP manual for comodo V3.

will comodo firewall work if windows firewall/ICS services is disabled is it really requred with comodo V3