how to open port 3306 at comodo internet security?

I installed xampp 1.7.7 on windows 7 x64 with comodo internet security 2012.

Though windows firewall is disabled, I opened port 3306 at in and out boud at windows firewall.

And I opend port 3306 at Network control Rules of comodo internet security.

* Allow * TCP or UDP * In/Out * Source Address : Any Address * Destination Address : Any Address * Source Port: Any * Destination Port: 3306

This didn’t work, so changed source and destination ip to 127.0.0.1, but not worked.
And commented out “Enable alerts for loopbackrequests” at Alert Settings, not worked.

And, at “/windows/system32/drivers/hosts” file,

127.0.0.1 localhost ::1 localhost

And netstat is;;

TCP 0.0.0.0:3306 0.0.0.0:0 LISTENING InHost TCP 127.0.0.1:2390 127.0.0.1:2391 ESTABLISHED InHost TCP 127.0.0.1:2391 127.0.0.1:2390 ESTABLISHED InHost TCP 127.0.0.1:2392 127.0.0.1:2393 ESTABLISHED InHost TCP 127.0.0.1:2393 127.0.0.1:2392 ESTABLISHED InHost TCP 127.0.0.1:8080 127.0.0.1:12851 ESTABLISHED InHost TCP 127.0.0.1:8080 127.0.0.1:12960 CLOSE_WAIT InHost TCP 127.0.0.1:10000 0.0.0.0:0 LISTENING InHost TCP 127.0.0.1:12851 127.0.0.1:8080 ESTABLISHED InHost TCP 127.0.0.1:12960 127.0.0.1:8080 FIN_WAIT_2 InHost TCP 127.0.0.1:24001 0.0.0.0:0 LISTENING InHost TCP [::]:3306 [::]:0 LISTENING InHost

So I commented “::1” at “hosts” file.

127.0.0.1 localhost #::1 localhost

But same result.

Any helpful comment would be much appreciated.

Thanks in advance.

Just to clarify. You’ve changed the default port for Apache to 3306 and now you’re trying to create firewall rules to allow connections to this port?

Radaghast/ port 3306 is for mysql, and yes, I want to create firewall rules to allow connections to this port.

My bad, I forgot that was the default port for MySQL. Is there some reason you specifically need this port open? If you’re just doing remote administration, use phpMyAdmin…

Anyway, if you need this for something like MySQLWorkbench, create a Global rule that allows TCP In Port 3306 and a corresponding Application rule with the same details. If I remember correctly, the application rule should be created for mysqld.exe.

Try the following: (this assumes you’ve created the necessary privileges on your xampp server)

Global rule:

Action - Allow
Protocol - TCP
Direction - In
Source Address - Where ever you’re connecting from
Destination Address - Any
Source Port - Any
Destination Port - 3306

Application rule

Application name - mysqld.exe
Action - Allow
Protocol - TCP
Direction - In
Source Address - Where ever you’re connecting from
Destination Address - Any
Source Port - Any
Destination Port - 3306

Radaghast/ Yes, I like phpMyAdmin which I do most jobs.

I did according to your guide, and the result is this.

netstat -ant TCP 0.0.0.0:3306 0.0.0.0:0 LISTENING InHost TCP 127.0.0.1:3306 127.0.0.1:23375 FIN_WAIT_1 InHost TCP 127.0.0.1:3306 127.0.0.1:26340 FIN_WAIT_1 InHost TCP 127.0.0.1:3306 127.0.0.1:26349 FIN_WAIT_1 InHost TCP 127.0.0.1:3306 127.0.0.1:26356 FIN_WAIT_1 InHost TCP 127.0.0.1:3306 127.0.0.1:26359 FIN_WAIT_1 InHost TCP 127.0.0.1:3306 127.0.0.1:26422 FIN_WAIT_1 InHost TCP [::]:3306 [::]:0 LISTENING InHost

But stil the bworser could not open “http://localhost:8080/phpmyadmin”.

I’m missing something here. If I understand, you connecting to a local database, it’s not a remote connection and you’ve changed the default port for httpd from 80 to 8080?

Radaghast/ Yes. But i want to connect from localhost and remote if possible.
And the port is 8080 for httpd.

With phpMyAdmin, and a local connection all you need is a rule for localhost on IPv4 and IPv6 (if used) for httpd.exe

Application name - httpd.exe
Action - Allow
Protocol - TCP
Direction - Out
Source Address - Any
Destination Address - 127.0.0.1
Source Port - Any
Destination Port - 3306

Application name - httpd.exe
Action - Allow
Protocol - TCP
Direction - Out
Source Address - Any
Destination Address - IP6 ::1
Source Port - Any
Destination Port - 3306

For a remote connection:

Global rule:

Action - Allow
Protocol - TCP
Direction - In
Source Address - Where ever you’re connecting from
Destination Address - Any
Source Port - Any
Destination Port - 8080

Application rule

Application name - httpd.exe
Action - Allow
Protocol - TCP
Direction - In
Source Address - Where ever you’re connecting from
Destination Address - Any
Source Port - Any
Destination Port - 8080

Radaghast/ I followed your guide, but still problem at these addresses.

http://127.0.0.1:8080/phpmyadmin/
http://localhost:8080/phpmyadmin/
http://myserver.dyndns.org:8080/phpmyadmin/

And “netstat -ant” is this.

TCP 0.0.0.0:443 0.0.0.0:0 LISTENING InHost TCP 0.0.0.0:445 0.0.0.0:0 LISTENING InHost TCP 0.0.0.0:3306 0.0.0.0:0 LISTENING InHost TCP 0.0.0.0:8080 0.0.0.0:0 LISTENING InHost TCP 127.0.0.1:3306 127.0.0.1:4056 FIN_WAIT_1 InHost TCP 127.0.0.1:3306 127.0.0.1:4071 FIN_WAIT_1 InHost TCP 127.0.0.1:3306 127.0.0.1:4072 FIN_WAIT_1 InHost TCP 127.0.0.1:3306 127.0.0.1:4624 FIN_WAIT_1 InHost TCP 127.0.0.1:4049 127.0.0.1:8080 ESTABLISHED InHost TCP 127.0.0.1:4056 127.0.0.1:3306 ESTABLISHED InHost TCP 127.0.0.1:4071 127.0.0.1:3306 ESTABLISHED InHost TCP 127.0.0.1:4072 127.0.0.1:3306 ESTABLISHED InHost TCP 127.0.0.1:4622 127.0.0.1:8080 ESTABLISHED InHost TCP 127.0.0.1:4623 127.0.0.1:8080 ESTABLISHED InHost TCP 127.0.0.1:4624 127.0.0.1:3306 ESTABLISHED InHost TCP 127.0.0.1:8080 127.0.0.1:4049 ESTABLISHED InHost TCP 127.0.0.1:8080 127.0.0.1:4622 ESTABLISHED InHost TCP 127.0.0.1:8080 127.0.0.1:4623 ESTABLISHED InHost TCP 192.168.0.2:8080 192.168.0.1:4059 ESTABLISHED InHost TCP 192.168.0.2:8080 192.168.0.1:4060 ESTABLISHED InHost TCP [::]:443 [::]:0 LISTENING InHost TCP [::]:445 [::]:0 LISTENING InHost TCP [::]:3306 [::]:0 LISTENING InHost TCP [::]:8080 [::]:0 LISTENING InHost

Should the port 443 for httpd to be opened? And about “Destination Address - IP6 ::1” I did as shown at attached picture, but does this correct?

[attachment deleted by admin]

Can you explain what the problem is?

http://myserver.dyndns.org:8080/phpmyadmin/

Adding Dynamic DNS may be a problem, I seem to remember CIS has problems with this. Perhaps someone who uses this kind of service has a better idea.

Should the port 443 for httpd to be opened?

If you’ve added a certificate to support https connections you can just add a rule for port 443.

And about "Destination Address - IP6 ::1" I did as shown at attached picture, but does this correct?

That looks correct.

[attachment deleted by admin]

Radaghast/ Thanks you for your kindness.

  1. There is still a problem that mysql doesn’t respond, but I found some messages at windows folder as attached picture.
http://127.0.0.1:8080/phpmyadmin/ http://localhost:8080/phpmyadmin/
  1. About dyndns, I’ll try and googling.

  2. I made a rule for443, but I could not report at this time.

[attachment deleted by admin]

Have you checked ‘mysql_error.log’ for any additional details?

Yes, I checked everytime I restart mysqlm but there is nothing.

120418 12:12:45 [Note] Plugin 'FEDERATED' is disabled. 120418 12:12:45 InnoDB: The InnoDB memory heap is disabled 120418 12:12:45 InnoDB: Mutexes and rw_locks use Windows interlocked functions 120418 12:12:45 InnoDB: Compressed tables use zlib 1.2.3 120418 12:12:45 InnoDB: Initializing buffer pool, size = 16.0M 120418 12:12:45 InnoDB: Completed initialization of buffer pool 120418 12:12:45 InnoDB: highest supported file format is Barracuda. 120418 12:12:45 InnoDB: Waiting for the background threads to start 120418 12:12:46 InnoDB: 1.1.8 started; log sequence number 1595675 120418 12:12:46 [Note] Event Scheduler: Loaded 0 events 120418 12:12:46 [Note] I:\apm_packages\xampp\mysql\bin\mysqld.exe: ready for connections. Version: '5.5.23' socket: '' port: 3306 MySQL Community Server (GPL)

And windows event log has nothing for this mysql, ans the apache error log has nothing.

[Wed Apr 18 11:45:25 2012] [notice] Child 2808: Released the start mutex [Wed Apr 18 11:45:54 2012] [notice] Parent: Forcing termination of child process 39c [Wed Apr 18 12:12:44 2012] [notice] Digest: generating secret for digest authentication ... [Wed Apr 18 12:12:44 2012] [notice] Digest: done [Wed Apr 18 12:12:45 2012] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations [Wed Apr 18 12:12:45 2012] [notice] Server built: Sep 10 2011 11:34:11 [Wed Apr 18 12:12:45 2012] [notice] Parent: Created child process 3292 [Wed Apr 18 12:12:45 2012] [notice] Digest: generating secret for digest authentication ... [Wed Apr 18 12:12:45 2012] [notice] Digest: done [Wed Apr 18 12:12:46 2012] [notice] Child 3292: Child process is running [Wed Apr 18 12:12:46 2012] [notice] Child 3292: Acquired the start mutex. [Wed Apr 18 12:12:46 2012] [notice] Child 3292: Starting 150 worker threads. [Wed Apr 18 12:12:46 2012] [notice] Child 3292: Starting thread to listen on port 443. [Wed Apr 18 12:12:46 2012] [notice] Child 3292: Starting thread to listen on port 443. [Wed Apr 18 12:12:46 2012] [notice] Child 3292: Starting thread to listen on port 8080. [Wed Apr 18 12:12:46 2012] [notice] Child 3292: Starting thread to listen on port 8080.

I could not find any clue for this problem.

Radaghast/ Rescently I re-installed windows with xampp and comodo.

Also I am trying to follow your guide, and please confirm whether I should set up your two guides or last one.

https://forums.comodo.com/firewall-help-cis/how-to-open-port-3306-at-comodo-internet-security-t83718.0.html;msg597864#msg597864

https://forums.comodo.com/firewall-help-cis/how-to-open-port-3306-at-comodo-internet-security-t83718.0.html;msg597895#msg597895

These should cover your needs.

Radaghast / I’ve tried to re-install xampp and comodo internet security with yuour guide, but mysql problem is still same.

But I install windows 7 x86 with xampp on virtulabox, at this machine xampp works fine. And I tried to install Comodo Internet Security, and xampp opens “http://localhost/phpmyadmin” without problem.

And I install windows 7 x64 with xampp on virtulabox, at this machine xampp works fine. And I tried to Comodo Internet Security, and xampp opens “http://localhost/phpmyadmin” without problem.

However, at host machine which is windows 7 x64, xampp with comodo internet security still culd not open “http://localhost:8080/phpmyadmin”.

I’ll re-install windows and try.

Thanks for your kind concern.

I’ve found 443 port problem.

As you can see at two attached pictures, the first picture shows one pid of httpd, but second picture shows two pids of httpd.

If the 443 port should be opened, please let me know how to open 443 port.

[attachment deleted by admin]

Unfortunately, only one of your images is available?

With regard to the PIDs, it’s quite normal for Apache to use multiple processes, it’s part of the Multi-Processing Module

Radaghast / The second file is here.

Ok I’ll check mpm, but I am using default httpd.conf, the only deferent is port 8080.

[attachment deleted by admin]

About mpm, I’ve copied mpmsection from the httpd.conf of virtualbox machine’s xampp which load “http://localhost/phpmyadmin” successfully.

User daemon Group daemon

But there is no 443 port’s pid.