How to get rid of error 1603

Hello, I was searching for clear instructions like this in the ‘‘Guides - CIS’’ or ‘’ Install / Setup / Configuration FAQ - CIS’’ section, hoping to find all I need to know in one place. At least for as long as this error isn’t fixed and is so often seen on this forum, I think searching for a solution all over the forum takes too much time and there should be one nice help instruction where you have all the info you need to install your new Comodo product. Since there wasn’t one I took the time to make one. Cheesy

if you had error 1603 when trying to install the newest version of Comodo, then you most likely had an older version of Comodo installed at some point in time (maybe not even recently) on the system.
Am I right? Some people on the forum talk about this problem as if kernel drivers or Windows Installer versions, etc. were the source of this problem, but I don’t think it’s a coincidence, that at least when I was reading the forum, almost everybody who got the error 1603 had an older version of Comodo. That is why I believe that the source of this error are the ‘leftovers’ of the previusely installed comodo product. At least this is my experience also on more than one machines…

If the source of this problem was kernel drivers or Windows Installer versions, etc., wouldn’t this error also appear when trying to install some other product and not just Comodo? Smiley I might be wrong about this, but if you had an older version of Comodo installed at some point in time on your system, then before you give up on Comodo or take some drastic measures on your system, maybe you should try what worked for me:

Step 1
Use comodo clean up tool:
More info here:;msg259617#msg259617

Step 2

If you are still getting error 1603 do this (it worked on one of my machines where the comodo clean up tool by itself didn’t do the trick):

Step 1
Run CCleaner, Comodo System Cleaner, KCleaner, Advanced SystemCare, EasyCleaner or similar tool (all mentioned are free).

Step 2
Click the Start button. Click Run. In the text field, type services.msc then click OK. Scroll down to find the service Windows Management Instrumentation. Right click it and then select Stop.

Step 3
Close out of Services back to the desktop. Navigate to \Windows\System32\WBEM\ by right-clicking the Start button and select Explore. Find the folder marked Windows. Double-click the folder to open it and scroll down until you find the folder named System32. Double-click that folder and then scroll down until you find the folder marked WBEM. Double-click that folder. Right-click on the Repository folder and click Delete. Click OK on any windows that appear.

Step 4
Close out of Windows Explorer. Click Start > Run > services.msc to go to Services. Now find Windows Management Instrumentation, right-click it and select start. Now restart your computer. Upon reboot, Comodo will no longer be listed as a firewall option in Windows Security Center.

Step 5
Click Start > Run > regedit. Now find and remove HKLM\Software\Microsoft\Windows\CurrentVersion\Uninstall\Comodo Internet Security and/or Comodo Personal Firewall key’s if present.

Step 6

If that didn’t help then you can also try:

  • Install the latest version of Windows installer:

  • Uninstall Daemon tools + delete all keys of Daemon in registry, then restart PC (seemed to work for one comodo user on the forum)

  • Tested only on Windows XP SP3 by a Comodo forum member → downloaded Combofix.exe from Bleeping Computer. The download link is: If you have problem with the above link then try: ComboFix: A guide and tutorial on using ComboFix. You will find the combofix.exe link on this page. I cannot emphasise strongly enough - only download Bleeping Computer’s own Combofix.exe. → Run Combofix.exe and follow the instructions very carefully and to the letter. Read through the Generated Report from Combofix.exe, might point out future problems. Install Comodo Internet Security 4.0 Setup file.

  • Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

  • Search through registry for keys having the word “comodo” anywhere in the name or contents and delete them.

Also delete keys having a subkey named 0000 and having a comodo content entry within.
These keys start with the word LEGACY_
BE CAREFUL only those that have a subkey 0000 having values related to comodo (you see the word comodo at least once in every 0000 subkey)
These are :
LEGACY_CMDAGENT (and 0000 subkey)
LEGACY_CMDGUARD (and 0000 subkey)
LEGACY_CMDHLP (and 0000 subkey)

You cannot delete these unless you change the permissions to everyone giving full control (to do so right click on the key → Permissions → give Owner’s right full permission → Ok → now delete the keys.).
Then you can delete these “sticky entries” that cause CIS 4 to “roll back”.

Here is another list of keys that should be removed:

CIS 4 should then install properly

Other possible problems:

  • Short file name creation is disabled on the target machine (regedit, navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem, make sure the value “NtfsDisable8dot3NameCreation” is equal to 0).
  • An Install Script custom action is prototyped incorrectly.
  • A file is locked and cannot be overwritten. (reboot & try again)
  • The Microsoft Windows Installer Service is not installed correctly (reinstall from
  • The Windows Temp folders are full (clear your rubbish bin).
  • The setup was corrupted after installation and, therefore, fails with this error during un-installation (download again, check file system for erros).
  • A general error occurred during the installation.
  • Print and File sharing is not installed or enabled when installing MSDE 2000.

I would also like to add that I was installing CIS on 4 differnt computers (Win XP, SP3). Before this all had an older version of Comodo Firewall installed. Following these steps I culd even (clean) install and use CIS with working Avira Antivir Personal* on one and Avast!** on another computer without problems. I did this out of curiosity because some users said they had to uninstall one or the product to install CIS. That they had to choose. The second two computers both have CIS for their resident AV, firewall etc. and also work great.

Saying this, one should realise that what worked on one computer might not work on another and when installing a second AV on a computer, even if just for a backup scanner, one must be carefull and make a system backup or at least a restore point, because you never know…

*I just disabled its realtime scanner while installing, and then disabled realtime scanner in CIS and activated back Antivir realtime scanner, because I am using Antivir for realtime and Comodo antivirus only for a backup scanner… I also excluded eachothers processes and directorys in both programs so that Comodo doesn’t scan Antivir and Antivir doesn’t scan Comodo. After that I rebooted.

**I disabled Avast! realtime shields and in settings → troubleshooting I enabled all settings except ‘‘enable rootkit scan on startup’’. Here I also decided to use Comodo AV for a backup scanner and Avast! Free for the resident, so I excluded in it all Comodo processes and folders. After that I rebooted.

Thank you SO MUCH, Mors!!

Your procedure worked like a charm when nothing else did. I had been trying for hours, and am a very comfortable computer user.

I followed all the directions in your first post here (up through the line
“CIS 4 should then install properly” )

9000 thumbs up! :-TU

I’m happy my post helped someone. ^^