If you guys are stuck on the 5784 update and every time you check for updates manually you get a prompt about updates failing or it says that you are up to date do the following.

Go to c:\programs\comodo\comodo internet security\scanners you will have a bases.cav file and a bases.$$$ file. The $$$ file is left over from a bad update. You have two things to try.

First to try is to delete the bases.$$$ file reboot and try to update now. If it works you are golden. If it does not work try the next thing.

Delete the bases.cav and bases.$$$ file. The go to c:\programs\comodo\comodo internet security\repair folder and copy the bases.cav file from there and past it in the scanners folder. Now reboot and download the whole update again. It should work fine now.

Also, if you cannot delete the files in normal mode, you will have to restart into safe mode.

EDIT: In case someone needs the original bases.cav file I extracted it out of the installer and attached it here.

EDIT 2: I think I have come up with another way to fix this so you don’t have to download the whole bases file again, I can’t try it becasue I fixed mine but I would appreciate if someone can tell me if it work. Ok here goes.

You boot into normal mode, go to c:\programs\comodo\comodo internet security\scanners right click on the bases.cav file ( should be over 90mb) and past it to your desk top. Next download the repair bases file from my post and save it to the desktop.

Now boot into safe mode, go to c:\programs\comodo\comodo internet security\repair and delete the bases.cav file from there and replace it with the one I provided you. Also right click on it and select copy. Then go to c:\programs\comodo\comodo internet security\scanner and delete the bases.$$$ and bases.cav file. Then paset the the copy of the bases.cav file that is now in the repair folder. Reboot into normal mode.

Once booted into normal mode, reboot into safe mode again. This time go to :\programs\comodo\comodo internet security\scanner and replace the bases.cav (9mb) file with the one from the desktop you saved earlier. Now reboot into normal mode and try to update.

Please let me know if this works.

[attachment deleted by admin]


Add the version of the AV database installed (5784…) in the AV summary.

Thanks, I think that I had this problem with the first beta.

Can you guy’s please post OS details?

I had this issue on Win7, x32
According to “Tasks launched” logging I hit error code 0x80004005 at a round 10:37 PM GMT+1 time.

I had it yesterdag evening. It started right after Comodo fixed there update servers.
In the logs I have the same error that you posted. But I also get a popup with unsuccesfull update and there is another number -214…… (or something, I’m not at home now).

OS: Windows XP SP 3 Dutch

windows 7 X 64 and no issues. Actually yesterday i got problems all the day long with a message that my av database is up to date but i the evening (about 10 p.m. GMT time) i got my update again

P.S. Sorry for confusing you guys, I use CIS 4.1 so probably my post is not actual for beta corner.

Sorry again

must be that if the update fails in V5, it gets stuck and can’t get unstuck. So when the updates resume you can’t update anymore. But in version 4.1 when an update fails it rolls back to the original files and when the updates resume it can resume updating too. This is something that should be fixed.

And the error message is also not correct. It says something about an internet connection not available. In fact the definitions are downloaded (I see them in the temp directory somewhere in documents and settings). But they cannot be applied.

thanks languy99

since I didn’t see the corrupted file , I followed the 2nd method .However , it didn’t work :frowning:

if what you proposed is true , then an urgent fix should be released as soon as possible :wink:

tested on vmware 7
windows xp sp3
CIS 5 BETA 4 , stock

I also had this problem and i did a fresh install.

hi Languy99

Thanks for your help. I was getting really frustrated but the second method you explained worked perfectly. And people say that you are just a pretty face. How wrong they are.

shadha :slight_smile:

the second method helped me too.
Thank you.

i have both version (4 and 5) installed on different pc and both of them fail to update. V4 said it failed to update virus signature database, check internet connection. V5 said virus signature is up to date but its not.

Hi zurggie, can you post a screenshot of the About screen from version 4?
As far as I know this is the first report for version 4 having the 5784 DB issue…

Version 4.1 OK here.
Had version 5 stuck but OK now after resetting to database 1.

Win7 32 bit in each case (separate PCs).

Already revert to database 1 for v4, but update fail halfway. Will try again today if fail again, i will post a screen shot.

same here. method 2 didn’t work for me either.

For v4 follow Where can i download the latest full AV database?.

This topic is for problems with the av update of v5.

had a slight “hick up” on both my computers this weekend, Win 7 Home Prem x64 and on the XP Pro x86, both gave security alerts, Comodo AV database out dated, security hazard etc. Went on to update and Comodo went back to normal with the old database.
After downloading the latest db 5826 and pasteing it in to Comodo 5.0 Beta Prem, all is good!
Mats H

Eric don’t scare v4 users away :wink:
It’s very important to know that also v4 is affected… So please if you have (or had this issue) on v4 post here also…

My problem gone away after full reinstall and download update manually. Now change back to v4 on all computer. Hope no more signature corrupt issues. Really give a headache. This happen once back in v3. Irony is, both happen when I about to promote CIS to my colleague. I wonder when will CIS be ready for an average joe.