How to disable Comodo Secure DNS?

Secure DNS is stopping me from accessing my cloud provider. When the page tells me it has blocked access I am given no option to override the block which I find infuriating. I disabled website filtering but Comodo is still filtering websites.

How can I stop Comodo from routing through your secure DNS servers please?
In the past that was an option during installation and I always selected not to use it. Now I have it forced on me.

  1. Check attachment
  2. Open Command promt, type:
ipconfig /flushdns
  1. Click enter.
  2. Restart internet connection.
  3. Clean web browser cache.

Please report websites here:

↓ ↓

Thanks very much Zbc. That fixed it.
I’m not going to report the website as good because I think their lack of a valid certificate warrants them being on Comodo’s block list however, I’ve been using their service to backup all my data for 2 years now and I have never had any issues with them.

My only feeling is that if Comodo blocks a site, the option to override the block should ALWAYS BE AVAILABLE to the user. As things stand, the first time you attempt to access a blocked site you are given the option to ignore the warning but if you click on it, the page reloads and Comodo blocks it again but this time the ignore option is no longer available.

What I can’t understand is why I still get website filtering when I have that option disabled in CIS?

Website filtering in CIS ≠ Secure DNS. It’s two different, separate things.