How to disable automatic check for program updates

Well I’ll give it a try, topic in vain already discussed here though.

I am using the Firewall only for which I am basically very grateful, great tool.

Yes I know it’s free, even so:
WTH isn’t there an option to disable the update entirely?

It is concerning that the message pops up several times a day and also
denied it comes back up again day after day.

Comodo hides this “whatever-they-call-this-trusty” thing somewhere deep
in the registry and I can’t get grip on it.

That’s the same attitude of mal- and spyware and at least same aggrevating.


I would advise updating it. It is always best to have your security program as up-to-date as possible.

However, if you wish to put off updating for a while you can open the Advanced Settings. Then go to the section for Updates. Under that you can either change the updater to check only after a few days, or you can disable it entirely.

Let me know if you have any questions.


Thanx for the response,

“you can open the Advanced Settings”

No, there ain’t such an option…
The “Option” window is a cripple (see attach).

“I would advise updating it.”
Basically I am not updating what’s working fine
just for the believe it might be better next.
Because “security reasons” without facts is just scare mongering.

[attachment deleted by admin]

See the green arrow in the right upper corner?
Click on it.

You should click the green arrow besides “Tasks”, then you will see “Advanced options” on the bottom.
After that, follow Chiron’s advice and you have done it :slight_smile:

Siketa, you beated me by few minutes :wink:

Double help or nothing…

In both v5 and v6 you can completely disable the automatic check for program updates. I am moving this to the appropriate help board.

I also changed the topic title to a more descriptive title.

no need to be so eager not to speak arrogant folks!

a simple option well hidden simplified by yourself into : “you can open the Advanced Settings” only.

click on option , recognize the very common GUI with its green arrow, click on tasks, click on Advanced tasks
and after 6 clicks you still not on target - no “Do not check” only one with boundaries.
nothing for amateurs.

reminds me on the Hitchhiker’s guide where the objection against the hyperspace bypass
“is at your local planning department in Alpha Centauri… too late to start making a fuss about it now”

but to be fair, you’ve been a help anyway.

thank you for that!


The main screen also has an advanced flipside when pushing the green arrow. From there it is only 3 steps.

Another strategy to get to advanced options quickly is to make a button which will show up in the Task bar at the bottom of the main screen. I have a button to Advanced Settings for example. Just right click on a button in the Taks interface and it will give you the option to make a button on the task bar.