How to block a web page

I am using Comodo firewall on my Windows 2003 server. I would like to block a website from accessing my webpages. I added the following security rule but it does not block the incoming webpage.

host name
I entered the webpage that I want to block

So obviously I am doing this incorrectly. I would greatly appreciate it if someone would stear me in the correct direction as to how to add this block.

Many thanks.

Hi and welcome,

Please see the following topic on how to block a website:

Also, I’d recommend updating CFP to the latest version:


Thank you for the information and welcome.

Everytime I update I loose all of my settings and my programs/scripts/updates are blocked. I just don’t have the time to re-enter everything with each update. I’m sure I’m doing something wrong there too. Do you have a solution to this problem too?

(:SAD) Unfortunately, that didn’t work. I go to their website click on their link and my website comes up - NOT blocked. I even had someone check what I did. According to them I did it exactly as posted.

Any other solutions?

Ok, I couldn’t say why applications would be blocked, but manually updating will cause you to loose all settings for CFP, but auto should keep all settings. Do you auto update or manually update?

Can you post what you have entered or post a screenshot of the application rules?


BLOCK and LOG IP OUT FROM IP [Any] TO IP NAME: [http://theWebsiteToBlockFromMyServer.htm] - - WHERE IPPROTO IS ANY


Yes, that looks correct. Have you moved this so that it is the first rule in the network monitor list? Just click on the rule and select ‘move up’.


It’s rule number zero

Ok, then it should it work. I’ll check this myself and see if I can block a website, but I know it has worked before.


Ok, can you try blocking another website, it doesn’t matter which one, and see if it works.


I tried another website and that wasn’t blocked either. Could there be something that is overriding this? I do have network control rules turned on.

Also, I don’t see where to turn on the automatic update. Would you mind directing me to that too please.

The only thing (as far as I’m aware) that may affect this would be if the rule was in the wrong place, but as you’ve mentioned it is number zero, that cannot be it as this is correct.
If you plan on updating then I think its best to continue any suggestions after - to see if the update solves the problem.

To turn on Auto update go to security>advanced>miscelleaneous (click configure)>and you will see ‘automatically check for program files updates’ & Automatically check Comodo dertified applications database’.
You can also update by clicking ‘updater’ at the top of CFP then click ‘Start’


It doesn’t work here either.

I ran the updater and re-booted the server. I am now at Version The site is still not blocked.

There is no warning about this in the user guide or in Help. Who would want to update manually if this means all settings are lost ? ???

BTW. I used the manual updater to get and no settings changed.

Do a WHO-IS on the domain that you are trying to block, maybe the site has multiple Servers/IP addresses it loads off?

A WHO-IS search should show all Servers/IP addresses that it is registered to use. (Argh, I’m giving up my filter bypassing secrets (:TNG) ).

Who-is search =

Me me me :wink:

But you can use a script to save the settings:,2366.0.html

But I think from version 3 of the firewall, there will be a “load/save configuration” feature inside the program.

The page I’m trying to block is a user’s html page from their RoadRunner account - not a commercial site or dedicated server. He has direct links on his html page to our server. Does this make a difference with what I’m trying to do?

I think you are misunderstanding what I mean by ‘manual update’. This is referring to uninstalling and reinstalling fresh from a new download, rather than using the auto updater of CFP. Uninstalling and reinstalling will cause you to loose all settings - auto update will not. You can back up using a script on the forums (as mentioned in a previous post).