How to allow Windows Remote Desktop running latest CIS

I used to run Windows XP SP3 w/ all latest updates (until support recently ended) using the built-in firewall alongside Comodo Anti-Virus. I had a single rule in the built-in firewall allowing TCP on port 3389 for RDP to work for me.

I am now running the latest CIS Anti-Virus + Firewall (Windows built-in firewall disabled). I cannot get RDP to work. I am quite new to this software firewall. How can I allow TCP on port 3389 once again so RDP will work properly? Please advise.

Thank you.

To you need to open the port (TCP 3389) in the global rules of the firewall as well as svchost.exe since it’s the host process for the RDP process in windows.

This may help

This worked. I’m not sure if allowing svchost assisted in making it work, because many svchosts were listed and I just chose one at random. But all is well for my RDP now.

Thank you!