How to allow SNTP?


I want to keep my Windows 2000 Pro laptop time correct by using SNTP, I have started the time service and configured it at the command promtp using “c:>net time /”

I have stopped it and started it again using “net stop w32time” and “net start w32time” etc. but when I do “net time” it says it can’t find the time server. I am guessing this is becuase Comodo is blocking it (it used to work on my Zonealarm installation but that had to go due to BSOD issues).

Can anyone help point me to what setting(s) I need to change?



Windows Time Synchronization uses svchost.exe, port 123 to connect to the Internet, so create this rule(%windir% is where your Windows-folder is located, for example C:\WINDOWS).

[b]Parent: %windir%\system32\services.exe
Application: %windir%\system32\svchost.exe

Action: Allow
Protocol: UDP or TCP
Direction: In/Out

Destination Port: 123[/b]

Svchost.exe also requires access to port 53,67 and 68 for Internet to work.