How to allow incoming request

I have a remote control program that uses one port. When I remove Comodo FW, it can get into my computer. When I start the FW, I can’t get in. How can I open that one port and allow the program to connect. BTW, the program is setup to connect in two ways: (1) on local network, (2) from the internet using that one port.

I used network control rules to allow incoming traffic on my network, but still need help in opening a port from outside my network (from the internet). BTW - I have my router set so the port is open (port forwarding).

Welcome in the forums (:HUG)

Check here

  1. Locate the application you want to open a specific port for in Application Control rules menu and double click it.
  2. Checkmark the “Apply the following criteria” radio button and then click the Destination Port tab (you’ll see the tab appear once you checkmark that radio button).
  3. Checkmark the “Single Port” radio button and then type in the port number you want to add.

Zito, I did what you said, but I also had to do one more thing for it to work:
Under Network Control Rules,
Add a new rule
Allow TCP/UDP, in/out
Source IP = any
Destination IP = any
Source Port = any
Destination Port = single port (with mine filled in)
Move the new rule above the one that blocks IP protocols.
Anything else would not work.

Now here is my question - can I assume that this is safe?


as i did understand use 2 rules for in out, for blocking is in/out ok as far as i understood comodo.
(however id use all time 2 instances)

and safe is just you navigate, your scanner sees, might your registry tracker tells you.

sorry if i misread the term “safe”.


PS: you said you want a single port open, then specify the port by number or range, then if you just use the remote on fixed trusted ips, of course enter them.
narrow all items as close are still working.

and move the application top most, due its your NET

means you delete all apps enter your REMOTE, and then redo learn mode,

which is might a little bug (missing moving apps button), but a REMOTE is most risky action INET give

Assuming you’re the only one that uses this remote program to access the machine, you just need to specify the IP address of the remote computer. UDP shouldn’t be necessary since that protocol is outbound only i.e. it doesn’t require confirmation that the packet has been received as is the case with TCP. However, check the program’s setup menu just in case.
Setup instructions are defined in the Help menu under Firewall Security → Application Monitor → Add a New Application.

For your own safety though, go to and run a port scan on the port you’ve opened. When the site loads, click the “Shields Up” banner and then the link in the second menu which follows by the same name. After you’ve agreed to the terms of use, you’ll get a number of buttons, one of which is to scan for a specific port.

CorrineW, as I think meier12 suggested, it would be better to separate In from Out in your rules in this type of scenario (two separate rules). This is because of the reversal of Source/Destination information with each direction of travel. Keeping them separate reduces errors.

You should not, however, need to create an Out rule, as long as you still have the default rule: Allow TCP/UDP Out where Any = Source/Destination IP or Port.

Your In rule should be in Position ID 0.

As far as safety goes, yes it is as safe as it can be. Unlike some firewalls, CFP does not control whether a port is open or closed; the system does that. CFP simply controls whether or not traffic is allowed on that port. Due to the layered security monitors, in order for access to be granted in Network Monitor for an unsolicited Inbound connection, there must be an Allowed application (in Application Monitor) actively running and listening on the assigned port. If there is not such an application, Network Monitor will drop the traffic.