How to allow bluetooth traffic?

Hi everyone,

I have a bluetooth adapter (ANYCOM Blue USB-UHE 200/250) connected to my computer via USB. I use bluetooth mainly to connect with my mobile phone using Nokia’s PC Suite. After I installed COMODO Firewall PRO version, my bluetooth connection partly stopped working. Everything seemed really strange and I’d really appreciate your help!!

This is what has happened:

  • If I disable the service cmdagent.exe (COMODO Firewall Pro Helper Service) to run when the operating system starts (Win XP SP2) then the bluetooth works fine. Even if I turn on the service manually afterwards, it’s ok. However,when opening the firewall it warns me that “COMODO Application Agent is not running” (even after I turned it on). This probably means that the firewall isn’t really working, right?

  • If I don’t disable the service cmdagent.exe to run when the OS starts, then I can not pair the computer with the phone over bluetooth. If it is already paired, I can send a file to the phone but the PC Suite applications don’t work and says they get no contact with the phone. Maybe outgoing traffic is allowed but not incoming?!?

  • I’ve tried to log the blocked traffic but not succeeded. I’ve also turned off the firewall but it does not allow the bluetooth connection to work properly (if I connect with the phone over USB instead, the PC Suite applications work fine). Even when I turn off the firewall the service cmdagent.exe continues to run in the background and I can not turn it off. I guess that’s what blocks the bluetooth to run ok.

Please let me know how I can resolve the problem? And what is the function of cmdagent.exe?


Good day,

I would suggest to set the firewall in training mode before you connect your phone with bluetooth… also when you get a pop up related to the stuff you are doing, than just click allow and do not check remember for the safe side hehe (:WIN)…

But I do not think the problem is the firewall… Nokia pc suite and bluetooth do not work fine… You better use a data cable, that will guaranteed work. I myself do not use nokia pc suite to exchange data between pc and mobile phone… I just use build-in support of bluetooth in windows or use software that came with your bluetooth adapter…

ok, let me know if things worked out good for you, Have a nice day!


Thanks for your reply Fake vegeta!

I did try the training mode and it did not do anything. I never got a popup to allow the connection. As I wrote, now I have the service cmdagent.exe disabled during Windows XP startup and then the PC Suite over bluetooth works just fine. So my question remains:

How can I resolve the bluetooth problem without disabling the firewall function? And what is the function of cmdagent.exe?

Attached you find a print screen of my application rules which hasn’t helped…

[attachment deleted by admin]

wel maybe you can try reset the firewall to its standard configuration, sometimes this solves an unregular problem… resetting can be done by importing a fresh configuration file…

if you do not have one, I can send one to you…

Yes, please send me such a file and let me know how I install it!

Also, can you explain how I can log the blocked bluetooth traffic? Because I could not get it to appear in my log.

Finally, do you know what the function of cmdagent.exe is?


I can send you a fresh configuration file, is packed in the rar format. it is password protected. extract the file to your desktop.

Password = CFP

when the file is on your desktop, do the following:

  • open cfp and go to the miscellaneous tab.
  • click on manage my configurations
  • click on import and in the submenu on import
  • in the pop up screen, browse to your desktop and select the configuration file…
  • wait til cfp has imported the configuration file…

NOTE: when importing this config file, you will lose all of your current custom rules… so it is better to export your rules if the resetting has not worked out for you…

For exporting:

  • click on manage my configurations and click on export
  • in the submenu click on on the confiuration that has a checkmark and name the configuration
  • wait till the exporting is done

the logging goes automatic, cfp has currently no options to set up logging… unless you disabled logging by yourself, cfp will log every event by itself…

NOTE: things that are being allowed will not be logged, because you allowed bluetooth traffic you see nothing about that in the logs…

cfp.exe and cmdagent.exe are the core components of the firewall, they are seen in the proceslist…

I hope this clears thing out for you, let me know if things worked out good for you… (:WIN)

[attachment deleted by admin]

Hi, thanks for the support.

What really solved my problems was upgrading from CFP version 3.0 to 3.5. I guess there must have been some bug in 3.0 (I read something about fragmented packages still being blocked when not supposed to)

Wish you all a good week!