How do I update BoClean?

Sorry if this question has already been asked, but I can’t find any others having this problem. Are updates available for the new Boclean? I downloaded and installed the program, but when I click on “Check for Update,” it doesn’t connect to any update server. Is there a way manually download updates, or how is it updated? I am brand new to BoClean so am not sure how to proceed. By the way, the programs shows last update as being 4/19.

Have you rebooted since installing?
Mine updated to 4/23.

Yes. I’ve actually rebooted a couple of times. All I am getting is a message stating “Updating at Comodo.com,” but there is no net traffic being generated from the server.

You might want to run a sniffer and see where the packets are being blocked.

I’ve tried that as well as a few other tricks. It looks like the program is making initial contact with the server, but then the connection stops as soon as it starts. Here is the data from the sniffer:

[4/22/2007 9:58:00 PM:812]
220 ProFTPD 1.2.10 Server (Trustix AntiVirus) [74.52.200.146]

[4/22/2007 9:58:00 PM:812]
USER anonymous

[4/22/2007 9:58:01 PM:312]
331 Anonymous login ok, send your complete email address as your password.

[4/22/2007 9:58:01 PM:312]
PASS boclean4.23

[4/22/2007 9:58:01 PM:312]
230 Anonymous access granted, restrictions apply.

[4/22/2007 9:58:01 PM:312]
CWD pub

[4/22/2007 9:58:01 PM:812]
250 CWD command successful

[4/22/2007 9:58:01 PM:812]
TYPE A

[4/22/2007 9:58:01 PM:812]
200 Type set to A

[4/22/2007 9:58:01 PM:812]
PASV

[4/22/2007 9:58:02 PM:312]
227 Entering Passive Mode (74,52,200,146,156,173).

I’m pretty adept at firewalls but sniffer interpretations is another matter. Am not familiar with the term “entering passive mode.” I would imagine it would have something to do with Passive FTP, which I’ve never dealt with before and know nothing about. That being the case, I have no idea what kind of firewall rule I need to make in order to allow the packets, if indeed they are being blocked. However, I don’t find anything in the Comodo firewall log that shows me anything has been blocked from that particular IP.

I’m not sure what’s going on myself, but perhaps someone else can make some sense of this for you. What’s going on is that somehow your FTP (and this is in IE as well since we use IE’s WININET library for the update download) is set to ASCII mode instead of BINARY and I’m guessing that since the update download is encrypted, the “high ASCII characters” in there are causing your FTP to disconnect.

What I’m not sure of is where you’d change the settings … but that’s what’s going on - your FTP configuration is set for ASCII and the defaults for IE and most FTP clients are almost always set for BINARY and you need a binary mode to get the file. Now what got misconfigured or where, that’s what I don’t know. Hopefully someone else can pick up on this though and guide you …

FWIW, here is what I see on mine after entering passive mode.

[attachment deleted by admin]

Actually the ASCII is simply my preference in the sniffer program. Everything else is configured for binary. I finally figured out that the problem is that I had the higher ports (5001-65355) blocked in my firewall rules, and BoClean was blocked at the 40000 port range. So I had to create a special rule allowing the server IP to connect to the higher ports. BoClean now shows it was updated 4/23. I’ve never had a program before that needed the higher ports before, so it threw me for a loop.

Yeah, we were kinda stuck doing passive (PASV) mode owing to ZoneAlarm and a few other firewalls that just wouldn’t allow “normal” FTP and so went with that a long time ago because many firewalls just wouldn’t allow “normal.” And the “tinfoil helmet” squad didn’t like having their end “act as a server” according to their firewalls given the way normal FTP mode works. So we just went along since it always normally works. :-\