How do I prevent Incoming Traffic with the firewall

I am somewhat new to Comodo Firewall, but have read a lot about it, and I have used it for the past few months. I am running a Vista Home Premium 64 bit Operating system. Yesterday, I noticed in My Network and Sharing Center, I saw that File Sharing was turned on. This concerned me, since I might someday be subject to someone coming thru my the Internet Connetion, and viewing or taking some of my files. I tried to turn it of, but the message stated that it had to be turned off via the Firewall. I looked through the menus in Comodo, but could not locate the words “File Sharing”. What area in the menus do I turn file sharing off? Thank you in advance for your time and assistance. >:(

Hi BB9,

First question, is the standard Windows firewall disabled?

File sharing is actually a property of the network adapter card although you can create firewall rules to block the protocols and ports involved.

Open the properties for your network adapter, select Networking/Internet Protocol v4 and uncheck the boxes for ‘client for Microsoft Networks’ and ‘File and print sharing for Microsoft networks’. Better still, after you’ve selected Internet Protocol v4 select properties/Advanced/WINS and disable NetBIOS over TCP/IP

The Windows Firewall was dis-abled/turned off, when I installed Comodo Firewall. I did every thing you mentioned in your reply, and re-booted my system, but in the “Network Sharing Center” under “Sharing and Discovery” I still see “File Sharing” as “ON”. The button is greyed out, and it still states that I can use my Firewall Program to change this setting.

[attachment deleted by admin]

The only way you can change these settings is by having the Windows firewall on.

It is the same on my Vista computer even thought I have disabled file sharing in the Network connection properties for my adaptor.

Please read here and here.

If you use Search on the forum File Sharing on Vista there are more Topics on this question.