How do I force Comodo to show up ONLY in the system tray after boot ?

I upgraded all my computers from Comodo V2 to V3 a couple of weeks ago. Everything works great except that every time I boot my main computer, which has a dual screen setup, the Comodo window shows up in the middle of one of the 2 screens instead of start “silently” (only in the system tray). My other 2 computers don’t have this problem, and only the Comodo firewall system tray icon is visible once the application is launched.

I thought the problem was the dual screen setup but it turned out I was wrong. It doesn’t matter which type of screen configuration (dual, single, cloned, extended) I choose, the Comodo window is visible every time I start the computer. I know it’s not a big deal but this little problem is driving me crazy ???. I have tried adding a “/background” command to the cfp.exe -h registry line, I also tried creating a batch file that calls the START /B /MIN command, I tried uninstalling Comodo and deleting all the Comodo files and registry entries and installing again, but no luck so far.

Does anybody know how to fix this problem and force Comodo to show up only in the system tray after boot?

Thanks a lot for your help!!

It shouldn’t show at all. What version are you using?

I’m using version

Open “regedit”. Go to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run. You will find two entries pointing to “cfp.exe”. Delete one and problem solved.

i have the exact same problem after Comodo updated itself some days ago. Your tip solved the problem.


Unfortunately this solution didn’t work for me.

If I configure my system with a single screen it does work. However, when I connect my second monitor the the comodo window is in the middle of the screen every time I boot the computer.

Btw, the 2 entries pointing to cfp.exe were:

COMODO firewall Pro REG_SZ “D:\Program Files\Comodo\Firewall\cfp.exe” -h

COMODO Internet Security REG_SZ “D:\Program Files\Comodo\Firewall\cfp.exe” -h

Does it matter which one is removed (I would think no, but you never know)?. I deleted the bottom one (the one labeled “Internet security”).

Your version is extremely old. I’d uninstall using revo uninstaller in advanced mode (pay attention), reboot and download a fresh copy.

Also, you’ll probably want to export your settings in a folder other than Comodo to import once you’ve downloaded a new copt.

Actually my actual version is 3.5.54375.427. The is the one I had in march when I switched to Comodo Firewall V3 and started having the problem. During that time and now I did a fresh reinstall of windows around July and after installing Comodo same problem: dual screen = comodo not loading minimized.

I guess I’ll have to get used to it (which I am pretty much now) :-\

I had the same problem but, having Ccleaner, resolved it by going to Tools> Startup in that and disabling cfp.exe there… Just another way that I thought those who don’t like delving in regedit might prefer.