How do I exclude a directory from Defence+?

I am a software developer and I am coding and building .exe files. Since my code changes frequently, so the yielding exe file changes. Every time an exe file changes, Defense+ detects this changes and ask me again and again and again if it should be isolated or not.

I get this warning message:

How do I stop Defense+ scanning this certain directory where my frequently changing exe files are in.

I tried doing it myself, I changed some settings to exclude that directory, but it didn’t work. There are too much settings and they just got me confused. I need your help on this matter.


In order to set up a rule for a folder, you’ll need to set up a file group.

Go to Defense+ → Computer Security Policy → Protected Files and Folders, and click the Groups button. Click Add → Select From → Browse, and navigate to the folder you want to add. Give the group a name.

Then go to Defense+ → Computer Security Policy → Defense+ Rules then click Add, then Select → File Groups, and select the new group you just created. Click the radio button next to Use a Predefined Policy and select Installer or Updater.

Now CIS will let your self-compiled .exe’s to do whatever they want without any alerts.

I did your instructions up to the red colored part. There is no radio button “next to Use a Predefined Policy”. I’m stuck at this point.

[attachment deleted by admin]

Thank you for the screen shot. Now I completed your instructions.

But now, there is a different problem. My compiler says that the exe file is not writable. It can not generate a new exe file or modify the current one for some reason. It give the following message:

error LNK1168: cannot open C:\...\program.exe for writing

I can delete the exe file by using Windows explorer. Doing so, the compiler can successfully create a new exe file when I build the code. But afterwards, when I modify the code and build it for a second time, it again gives the error message above.

So, what do I do now?

I don’t know because now Defense+ should be keeping its hands off the file. Is the compiler a trusted application? If you disable Defense+ temporarily from the tray icon, does this error message go away?

i can quest whats happening…
now your compiled files are “protected” by comodo, when the compiler eq: “mingw” tries to modify it the access is blocked

to sove it, you must set ALL you IDE exes and compilers files to installer/updater, sometimes “trusted” is not enough for comodo to le it do anything

I disabled Defense+, but there are still the same write errors. Disabling did not change anything.

I set all the IDE files, code files, exe files as installer/updater. I set an exclusion for the exe folder under antivirus settings. It is still the same. It still gives the same error.

But, there is something strange. After I get that write error, if I wait for a minute and just try again, I don’t get any error. I get the error after my first attempt to compile and run my changed code; waiting for a minute and then trying again compiling and running succeeds.
Then, when I change my code again, again I get the same error. And again I have to wait for a minute and try again to succeed… and so on.

If disabling Defense+ has no effect, this suggests that the issue isn’t due to Defense+. However, a temporary disabling still has drivers pertaining to Defense+ loaded.

If you go to Defense+ → Defense+ Settings → General Settings, and select Deactivate Defense+ permanently, then click OK and restart your system. Defense+ will be completely disabled at this point. Does the error still occur?

I completely disabled from the setting you told me. The same problem still exists. Does it mean that, the problem is not related to Comodo?

If you have used the disable permanently option, there are no parts of Defense+ loaded when you start your machine. I wouldn’t think it could possibly be interfering with your compiler.

Have you used this compiler before installing CIS? It might be a bit of a pain, but you could try uninstalling CIS and see if the problem still exists.

The compiler is Visual Studio. Until yesterday, I was using both Visual Studio, Avast Antivirus and Comodo Firewall peacefully. Yesterday, I uninstalled Avast Antivirus and Comodo Firewall, and installed Comodo Internet Security instead (Except for this, I didn’t do any single tiny change on my system, didn’t install anything, didn’t alter settings of any software, just didn’t do anything.). After this modification, these error messages started.

If D+ wasn’t having any issues previously, I don’t know why it would start now.

I’ll ask the other moderators if they have any input.

Edit: Dennis2 asks, Are there any remnants of previous security software left on the machine? If you disable the AV, do you still have the problem?

Finally I solved the issue.

It was because of a very silly and frustrating reason. It was because of a Visual Studio bug, the Windows service “Application Experience” being turned off…

Please see this thread for more information.

After CIS installation I turned off several Windows services before rebooting my machine. And afterwards, I completely forgot about this. In this thread, I said that I didn’t do any changes besides CIS installation. I’m sorry about that, I forgot these disabled services.

After trying everything (virus scan, running chkdsk for 6 hours, reinstalling CIS,…), I googled the linker error to find the real reason. I just turned on that service, and the error disappeared.

Thank you for helping me, and again I’m sorry for taking your time because of my own mistake.

Don’t worry about it. I’m glad you’ve got it fixed! :slight_smile: