How do i enable firewall ports to allow media center extender to work?

I need some help trying to open these ports:
1900 UPnP Framework UDP My network (subnet) only
3390 Remote Media Center Experience TCP Any computer (including those on the Internet)
3776 Media Center Extender Service UDP Any computer (including those on the Internet)
5555 Media Streaming TCP My network (subnet) only
7777 Network Validation UDP My network (subnet) only

I just copied those from the help section of media center extender. I dont know where or how i have to go to enable them.

Welcome to the Forum, soul_eater774.

Try removing any existing firewall rules, then place the Firewall into Training mode, run the program for a bit, then you should be able to place the firewall back into the mode you were using.

To access the rules, click Firewall/Advanced/Network Security Policy. Scroll down to the program name, select it, and remove it. Click ‘OK’.
To place the firewall into Training mode, right click the tray icon, select Firewall Security Level/Training mode.