How Do I Eliminate The Summary/Config Splash Screen On Bootup?


I apologize if this topic has been covered, but in my search I found nothing regarding version 5.

I am running version 5.016xxx after upgrading from 3.xx with Windows XP SP3.

I know there’s a -h parameter for version 3.xx to hide the splash screen, but could someone please tell me how to hide the screen in version

I’m not sure where CIS loads from since there’s no icon in the startup folder, so I don’t know where to go to enter a parameter setting for startup.

Thanks in advance for your help.


CFP.exe (GUI) starts from registry;

“C:\Program Files\COMODO\COMODO Internet Security\cfp.exe” -h

Must be an install option that controls that; my reg key already had that flag.

Thanks for your reply to my question.

I checked my registry and mine looks exactly like your example, including the -h parameter.

Is there any other setting somewhere that I should check?

Thanks again.

Some installs for some reason lose the -h.

Do you only see a single instance of the cfp.exe key? I recall a post where the user had two keys.

Thanks for your suggestion, but no luck yet…

After reading your message I searched the entire registry and added the -h after all instances of cfp.exe and then re-booted.

Problem still not solved…

Thanks again.

Please use Autoruns from M$ to see if there are duplicate entries, this is the only reason I know of that causes this behavior

Thanks for your reply.

Autoruns shows only one entry for CIS under HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run.

Very strange…

Thanks again.

Are you running Vista/Win7 with UAC?

Win XP SP3

as Administrator or equivalent account?


Do you know of a way to re-arrange the order in which programs/apps load on boot-up? I wonder if CIS loads first or last if that would make a difference? Just an idea…

You could try to temporary disable all other applications that start with your computer and see if CIS does as supposed to.

Only tool I know of is WinPatrol, that is capable of delay-starting several apps at system start (only startup folder type, not registry starters afaik).


I eliminated all startups, and CIS minimized to the tray.

I’ll re-enable the startup pgms and see if I can identify the conflict.

Thanks for your help.

Okay good news :-TU
Hope you can find what causes this, would be good to know why this happens.

I’m not sure what caused the problem or which pgm was the offender, but when I re-enabled all pgms, CIS now minimizes correctly on bootup. It’s possible that the registry re-ordered the startup list during the disabling and re-enabling of the pgms…

At any rate, the problem is solved.

Thanks very much for your help.