How do I define a new trusted application

I am trying to allow streaming from a particular web site that I think my comodo firewall is blocking (the picture keeps freezing). When I search for that web site in the browse command of ‘define a new trusted application’ I can’t find it anywhere to add. The software does’nt allow you to type it in either!

Any ideas please?

Welcome. :slight_smile:

The “define a new trusted application” lets you create rules for applications that run on your PC, not websites. Depending on the web browser you use, you need to set up the network rules for that browser.

Navigate to Firewall > Advanced > Network Security Policy and click “add”, “select”, “browse” and search for the executable file for the web browser you use, (e.g. firefox = firefox.exe, IE = iexplore.exe)

Now click “edit”, choose “predefined policy” and choose “web browser”. apply.

Nearly there.

I’ve got as far as clicking edit and it asks me to ‘select an item’! Do I have to add iexplorer.exe to the main window first, and what settings do I choose in that window before I proceed?

hmm ??? i don’t know much, but i’ve never encountered issue like that before ???
afaik CIS blocks applications from connecting to internet, not certain website. ???
are you sure it’s CIS blocking your website?

a risky way to make sure of it,is disable your firewall & see if that changes anything 88)

but let’s wait for expert opinion on this :slight_smile:

When I disable the firewall the streaming from web site works fine!

It must be your browser settings.

Yes. Check if iexplore.exe is listed in the Network Security Policy first. If it is, then you can highlight it, “edit”. If it’s not, select “add” and browse for it in “x:\Program Files\Internet Explorer\iexplore.exe”. then you can edit it and choose the predefined policy. see my screen shot. this is what the you should see when clicking “edit”.

[attachment deleted by admin]

Thanks for that. I’ve followed all your instructions and made those settings and picture still freezes on streaming! You also said it’s probably my web browser settings. Are those the settings in the ‘internet options’ of internet explorer? What would I need to alter in there?

I’m trying to stream the royal institute christmas lecture on ‘demand five’ web site. As a process of elimination, would you see if this program works for yourself please?


i can’t…i’m not in the UK.