How do I block an app i previously allowed in 6.x? (Removal of rule fails!)

I updated to Win 8.1 and 6.x yest. (As 5.x doesn’t work with 8.1 yet?) I was much happier with 5.x because if i allowed an app or program through the firewall, and then changed my mind and removed the rule, it would then alert me if the program tried again.

In 6.x, if i allow a program once, and then remove the rule, next time that program tries to access the net it goes straight through the firewall with nothing stopping it. I’ve tried this in all modes - safe, training and custom, and the result is the same. (Block All does work to block everything, but that’s hardly any help in this case :))

How do i block a program i’ve previously allowed? Please don’t tell me to set up a custom rule to block it, i want to be notified when it tries.

(I had this problem 9months back, and reverted to 5.x. Now that’s not an option. 5.x had the network monitor too, and would show me which applications were using bandwidth with a single click.)


I think rules persist through the session of the running instance of a program. Did you exit the app and try relaunching after the rule was removed?

Other then that you could make a custom rule,

Action: Ask
Protocol: IP
Direction: IN/OUT
Logging optional.

Read about the item: Create rules for safe applications.

I have that unchecked, and it makes no difference i can detect.

I have the software set to Custom Ruleset, and Winword.exe now has access - this is a program i have NEVER been asked to ok. It simply writes itself into the rules. Same with more than a few other programs, but that would be the most noted one. Why? Where is the setting to stop ALL traffic i don’t ok? Sorry to be a pain, i just can’t seem to find it!

I did find the advanced view tab tho, which brings back the network traffic. Nice to have it there.

EDIT: Sigh, i might have to investigate that blank IP ruleset option. I’m also going to try a restart after my AV scan is done. I swear i already have, but i may as well give it another go.

You can to remove the list of the entrusted files. (You looked there? )
You cn to remove the trusted.db file in the database folder and to reboot PC.
The list will be created again. (At least so in CIS 5 versions)
Also to look at the list of the entrusted suppliers. (Your program can be added as - User)
Put on a Firewall - Custom Ruleset Mode.
Do NOT show popup alerts - uncheck .
And more .
Do not include point - Create rules for safe applications . (HIPS - Default - off.)

Jenny, i followed your advice about settings. Not only that, i uninstalled CIS 6 completely, and started from scratch. I am using Custom Ruleset Mode, HIPS is disabled, and i have unchecked “Do not show popup alerts” and “Create rules for safe applications.” I did all the above while disconnected from the internet, just to be sure.

The exact same thing happens. Programs like Teamspeak 3 and any windows programs simply add themselves to the allowed list, and never ask for permission. New programs that have not run before installing CIS 6 yesterday still ask, but anything in the time since just goes right through the firewall.

I do the above, only to watch the file reappear three seconds later. It might be because while CIS 6 is installed there are two comodo processes running in the background that cannot be disabled in task manager. They are rewriting the file. I cannot delete it, and going into the application rules list right away makes no change, the list remains unchanged.

Why? What am i missing here? Have Comodo really designed a program that takes away this much control from the user? That control was the very reason i began with the program and recommended it to people. Has it been taken away?

How? Where on earth is the “ask” option? I only see Allow, Block, and copy other rules.


You probably do not understand.

And more . Do not include point - Create rules for safe applications . (HIPS - Default - off.)
This is the point in HIPS. All HIPS off is not necessary. Perhaps you have caching enabled. CIS remembers scanning.
How? Where on earth is the "ask" option? I only see Allow, Block, and copy other rules. More anything I can not tell you. I myself do not use the CIS 6. It's all just as in the CIS 5> only sub-menu pops up when you press in the bottom of the window. The blocked rules ( you rules) move to the very top. ( Above - System )

[attachment deleted by admin]

How do i disable caching? Is this Window memory caching of often-used programs? How do i set this off in CIS 6?

To address your other point - it makes no difference if HIPS is on or off, the same problem occurs. (Yes, i have turned off “Create rules for safe applications.”)

And your description of rulesets doesn’t tell me how to make things ask globally. You tell me how to modify existing rules for existing programs, not how to create a rule that makes something ask for permission all over again. And THAT is the problem i’m having.

Maybe i should go get zonealarm? Or would you care to recommend a firewall that works?

(Sorry, i do not mean to be rude. I know you are trying to help. I just find this completely stupid. CIS 5 worked just fine. CIS 6 is designed for ppl who do not want options? Is that right?)

Perhaps its the cloud lookup re-adding the trusted files.

Go Advanced Settings > Secruity Settings > File Ratings > File Rating Settings

Try unchecking Cloud look up & Analyze unknown files in cloud.

Nope, did that and it didn’t help. The programs just keep appearing in the list like magic :frowning:

Thank you for trying though :slight_smile: