How can I enable my printer sharing?

After install Comodo Firewall, All income access are blocked, include my shared printer.
I’m in a LAN and need to share my printer to others.
Who can teach me how to share it again by enable the Firewall?

Thanks a lot first!

The easiest Way…

Firstly, goto the Firewall Tab and select “Trusted Networks”

Delete your trusted network.

Disconnect and then reconnect to your network.

Upon the Network popup. Simply tick the box at the bottom which will enable you to trust the entire network.

You might need to log off and back on after that but you shouldn’t have any problems from there.

Alternatively, you can select “Stealth Ports Wizard” on the firewall tab and define the whole network as trusted from there.

P.S. You can also manually add the IP address of your printer to your Trusted Zone.


Thanks very much!
My installed program is ‘Comodo Firewall Pro’, there is a little different from your description, but I think I’ve understand you suggestion.

MY printer is plug to my PC via USB port, My IP is, I only want to share my printer to others such as 192.168.17.x, but I do not want others access my PC by any other way. I do not know if your suggestion could tackle my problem.

Thanks again, and apology for my poor English expression. ;D

Your best option then is to add your printer’s IP address into your “My Network Zones” as a single IP, that way it’s only trusting that particular IP Address.

I am away for Easter now and hopefully my suggestion above resolves your issue.

Should you require any more help before Monday night GMT (Greenwich Meantime (London)) Feel free to PM one of the other Mods.