How can I disable Quick Scan?

I recently switched from the Online-Armor firewall to Comodo Free Firewall. It’s been a vast improvement over Online-Armor. Last week, I decided also to install Comodo Free Antivirus. Apparently, the AV installer upgraded my installation to CIS 6.1.276867.2813 (I thought they would remain separate installations).

Now, every time I reboot my laptop, the AV Quick Scan runs. I’d like to disabled the scan so that it doesn’t do this. I tried to disable it in the advanced settings, and also tried to use the “never schedule” option, but neither worked. I’m also having the same problem that I saw in other threads where Quick Scan can’t be stopped and never finishes.

From what I’ve read in other threads, it seems that the only way to solve these issues is to uninstall and reinstall. Is that my only choice?

Did you ever let it complete the quick scan?

The reason I ask is that CIS does require an initial quick scan of the computer. However, after that one scan, assuming you disabled the scheduled scans, it will never perform a scan without you manually starting one.

Thus, if you didn’t already let it complete the quick scan, please let it finish the scan. That will solve your problem.

I never did allow the initial scan to finish. So, I just rebooted and I’ll let it do its thing.

While I’m waiting, I noticed that the scan has stalled for about 10 minutes on an IP: - it was progressing pretty rapidly through the file system before this, though.

The IP I listed is not assigned to any network adapter on my laptop, nor any machine in my network. Should I just continue to wait for it to complete?

Let it continue and see if it ever finishes.

By the way, do you have any other security programs currently installed on your computer?

Alright. It’s been going for about 2 hours now, stuck on the same IP.

I do have other security software installed. My company requires all domain machines to have Trend Micro Officescan installed, which includes the Trend Micro Network Security components. My installation of Officescan does not have on-access scanning enabled, nor on-demand scanning. But, I’m not able to completely disable or uninstall it. The also require us to have the Bradford Persistent Agent installed.

All very unfortunate, I know.

It’s possible that this is a conflict between the two security programs. Please try adding all other security applications to the AV exclusions of CIS. Also add all of CIS’s files to the exclusion list of the other security programs.

Please let me know if that helps.

I’m going to admit to doing something very rash due to my impatience. First, I was unable to make any adjustments to the other security apps because those features are locked out by my admin. Second, after several hours, I just couldn’t wait any longer.

I had to reboot my laptop anyway, so I decided to just uninstall and reinstall CFW. For some reason, I wasn’t able to locate the original installer, so I downloaded it again. BUT, and I really have no idea how this happened, I downloaded version 5 instead of 6. Somewhere in the middle of all this, it occurred to me that I should check my hosts file to see if anything was amiss. Sure enough, that odd IP ( was an entry pointing to some address that’s on my company’s intranet. I’m going to take a wild guess and say that commenting that IP out of my hosts file probably could have saved me a lot of time and frustration.

Now I have an older version of CFW, and I’m very hesitant to upgrade it. I no longer have CAV and/or CIS, but the firewall is working just fine. Should I bother to upgrade?

I would advise using V6.

Probably within the next few weeks an update will be offered to V5 users which will allow them to upgrade to V6. You can either wait for that update, or you can uninstall V5 and install V6 by following the advice which I give in this post.

OK, I performed a complete uninstall according to the post you mentioned. I also ran other cleanup utilities mentioned in the post for any other security apps I may have installed in the past. I performed a registry cleanup, temporary file cleanup and SFC/scannow. I disabled Bradford Persistent Agent, as well as Trend Micro Officescan (I found a way around it). I then installed V6 of CIS.

When the initial Quick Scan started, it no longer hung on that IP I mentioned in the previous post, but it did get stuck on - I cleared every entry from my hosts file (it’s now completely blank) and rebooted. The Quick Scan started again and didn’t hang on, but now it’s stuck on "Java™ Plugin-In 2 SSV Helper) and has remained stuck for about 2 hours now.

I’m starting to think that I just need to install CFW alone and try a different antivirus package from another vendor.

It’s possible that even when disabled there’s some background service which is interfering with the scan. Therefore, as it’s not possible to entirely remove them from your computer, what you could try doing is excluding that particular file from the antivirus.

Perhaps that will allow the scan to complete. However, if problems continue, likely due to the other security programs installed, perhaps using another AV would be prudent.

Chiron, thank you very much for your help with this. After more trial and error, I decided just to keep CFW v6 and go with another AV solution (Avast) - they’re working perfectly together so far.

Glad to hear that. Please let me know if you have any questions, or run into any other problems.

The redirect localhost to in the host file is suppose to be there by default. You may find some applications behaving oddly if they use the loopback for internal communication.

aim4it, Thanks for pointing that out. I was aware of that, but I was just at the end of my rope trying to resolve this issue :wink:

Do you have the highlighted object unchecked?

[attachment deleted by admin]

Actually, I’ve decided to just use CFW without CAV. I’m now running Avast AV, and it works very well with CFW. Thanks!