How can I add this to my firewall exception?

Hello. I have attempted to add an Nksp.exe file to my trusted list of applications. However, when I go to view the list I do not see Nksp.exe anywhere.

Hey and Welcome to the forum! :slight_smile:

go to firewal, click on “define new trusted application”, when you press on “select” go down to browser and there you have to find the exe that you want as trusted application (you find it usually in Program).

If you are kind of new using computer and you need to configurate you comodo look at this link


Hi there. Thank you for the welcome. =)

I have selected and added Nksp.exe as a trusted application, but when I go to view my entire list of trusted applications I do not see Nksp.exe listed.

Nksp.exe is not a program that can run by itself. It is part of another program. Do you think this is why Nksp.exe won’t show up in the trusted list even though I prompted the firewall to grant it access?

I will check the exe and i will inform you

so you have installed LastChaos. I would run program and accept all the alerts if I were you.

It’s good that you have added Nksp.exe to the trusted files in the firewall

What you can do is that you open defense+. Click on Trusted files, press Add and then choose the complete folder.

If you are a gamer I would recommend you to right click on the comodo icon, go to configuration and click on Proactive Security.


Where are you looking for this trusted file? If you’re looking in the Trusted Files list in Defense+, it’s not going to be there as you’ve trusted it in the firewall, not D+.

In order to view files you’ve trusted in the firewall, you need to go to Firewall → Network Security Policy → Application Rules. Looking at this list, you’ll see the Application name column, and the Treat as column. Look for nksp.exe and should see it is treated as a trusted application.

Thank you, HeffeD. It turns out I was looking in the wrong place. I see Nksp.exe in the place you specified. However, I still cannot get Last Chaos to run. I’ll do what Valentinchen suggested and try to add the complete folder to my trusted files list.

Thank you both for your input.

no poblem:) We are here to help:)


If you are still having problems getting it to run, delete the rules you’ve created for the application and enable training mode for the firewall and D+.

Log into the game and run it for a few minutes. Then log back out and switch back to your previous mode. Training mode should only be run for very short durations, and only for applications that you can’t get to work any other way.

Let us know if this helps.

Hello. I’ve done as you instructed for the firewall and D+ but things are still not working. My issue with the Last Chaos program is that I cannot get to the login screen. Even though I have internet connection, I have an error that says “Cannot connect to server” when I launch the game. This led me to believe that the Comodo firewall was blocking the program’s connection to the server.

I have also tried the following (in no particular order) but have still been unsuccessful in getting the game to start:

  • Ran the program as administrator
  • Restarted computer
  • Scanned for viruses, malware, and spyware on my system
  • Disk defragment
  • Cleaned the registry
  • Uninstalled Last Chaos and the folders from my C drive, then reinstalled Last Chaos

If there are other steps you’d like me to try please let me know. Thank you again for your time.

If you turn on the Windows firewall and disable the firewall in CIS, are you able to connect to the server?

Disabling the Comodo firewall and using Windows firewall doesn’t work either. Do you think this is a case of ethernet cable vs. wireless? This computer is currently hooked up to the internet with an ethernet cable. My wireless laptop works fine with Last Chaos and Comodo turned on. Or do you think this is a case where the computer cannot candle the requirements of the program, and perhaps that’s why I’m getting a “Cannot connect to server” error?

No, the Ethernet cable can’t block access to a particular server. If it was bad, you’d have no internet connectivity.

The router is suspect though. It may have a built-in firewall that is turned on that is actually doing the blocking. Does your laptop connect through the same router? Have you ever connected to the game servers with this computer, or is this a new development?

This computer and the laptop both connect to the internet through a linksys router. I have never tried to run Last Chaos on this computer until now.

Can you Ping the servers?

Try hitting the Start button, click on Run, type cmd, then at the prompt, type


Any packet loss? What is the average ping time? How do these compare to your laptop?

Hello. Here are the results from this computer:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss)

Approximate round trip times in milliseconds: Minimum = 61ms, Maximum = 63ms, Average = 61ms

And here are the results from my laptop:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss)

Approximate round trip times in milliseconds: Minimum = 61ms, Maximum = 73ms, Average = 64ms

So, the game runs on your laptop with CIS running. This tells us there is no inherent issue between CIS and the game.

Both machines use the same router. This tells us it’s not a router configuration issue.

Your machine that gives the connection error can actually reach the game servers. This tells us it’s not a connectivity issue.

I hate to say it, but this sounds like a problem for Last Chaos tech support. I don’t know anything about the game, so I don’t know what else to tell you to try. :frowning:

Ah, ok. I’ll get in touch with Last Chaos tech support. At least I don’t have to disable Comodo to run Last Chaos. Thanks for your help. :slight_smile: