[HOW] block an application from accessing local network

I’m sharing sometimes a license for an app with a friend on local network. In 2x versions, when I launched the app, comodo recognized connection requests, and asked whether to allow it.
I just declined the request, and both me and my friend were able to use the app at the same time.

Now 3x comodo is not asking. Whenever I run the app at same time with my friend, the app says “license already used” and exits.
I added the app to “blocked” list, tried to manually added the rules like block tcp/udp requests, but still, problem is here.
Only solution is to “Block all traffic” which helps, but it is not what I want.
Plz, any help with that? Or I just should get back to comodo 2x?

This is against forum policy, So I will NOT help you.

Illegal Stuff. Comodo is focused on building trust on the internet. Users discussing or inciting illegal activity, posting or requesting anything illegal or inappropriate will be warned or banned as appropriate.