Hosting a web server

How can I set my computer up to accept port 80 connections? Apparently the firewall isn’t allowing the connections. Can someone show me where or tell me how to set up the firewall to allow connections to my server on port 80 and 8080?

  1. Create a Global Rule:

Action: Allow
Protocol: TCP
Direction: In

Source Address: Any
Destination Address: Any
Source Port: Any
Destination Port: A Set of Ports: “WWW Ports” (or whatever it is called)

Make it the first rule on the list.

  1. Create the same rule for the executable of your Web-server in Application Rules.

This will allow youe Web-server to reveive incoming connections on ports 80, 8080, 443 (defined in the “WWW Ports” group).

What file(executable) do I use for IIS?

Don’t know, I don’t have it installed. Could be the inetinfo.exe. Check the Active Connections to see who’s listening on HTTP ports to make sure.

inetinfo.exe seems to be the one…now just to test it out see if it works…will let y’all know when I get to work and try from there.

Quick Question…how can I tell if the problem is my ISP or the firewall?

Can someone help me out?

Sorry for the double post, couldn’t see the edit button…till now.

No worries, I figured it out. I thought I had Windows XP Firewall turned off, apparently it was still on. It is now turned off and I am able to access it now. YAY

Thanks for all your help