hostfile access??

hi.i just wondered if somebody could help me here please?is there a way i can access my computers hostsfile so i can change it to read-only?? any help would be appreciated.thanks. :ilovecomodo:

Hi DARREN.1972

You can just set it manually as “Read only”

The location should be C:\WINDOWS\system32\drivers\etc
and for 64 bit platform %systemroot% \SysWOW64\drivers\etc

Actually just check Properties 1st – it’s most likely set as “read only” already

You can use such good management Software as HostsMan It has many features proving write-protection/backups/editing/etc.

In addition there several MS KB articles re: hosts file e.g Resetting Hosts file as far as I remember that will make it read only as well, but I cannot be sure since I was not using this for a long time

HostsMan with MVPS is my choice.

My regards

hi syberlynx.
ive looked in that location and i cant seem to find it.
could you please tell me exactly what im looking for.?
i looked for the obvious hostfiles and all i can find is hostapp.

kind regards.


Try looking in the same location SiberLynx mentioned for for 32bit systems.


If Wikipedia is correct, even several Microsoft support pages list the incorrect location of the HOSTS file, which is the path that SiberLynx mentioned for 64bit systems, but apparently the path is the same on both platforms.

Specifically, you are looking for a file that is simply named HOSTS.

You are absolutely right, HeffeD

The “SysWOW64” - path was added later in my reply and indeed was taken from the referred MS article/Fix page just in case (because not all user are reading references :wink: )
I did not have win 7 x64 at that time in order to check

Today I rechecked - there is \SysWOW64\drivers\ but no \etc\ there

& the Hosts file is in mentioned common path :-TU


i tried the hostsman program and it froze my computer up solid immediately after downloading some mvp hosts.
i dont know what the problem was and im not taking the chance again until i find out.
pity as it seems a good product.


That is probably because a large HOSTS file will bog down your system. The HOSTS file isn’t indexed, so each URL you visit, your system has to scan the file from the beginning searching for the domain. If your file is a few MB’s large, you can see that this will be a huge resource drain.

HOSTS file advocates alway recommend disabling the DNS cache service to avoid the system boggage, but then of course you’re killing the caching of recently visited domains, so each URL you visit will require a new DNS lookup, which of course slows down your browsing.

I personally would never recommend using the HOSTS file for blocking domains.

Edit: typo…

Hi Guys,

That issue has to be investigated … most likely by posting details about the system & settings to the developer (HostsMan forum)

No problems whatsoever here; no hogging on both systems (platforms) & using OpenDNS


As I understand his problem, the problem happened after added some files from MVPS hosts. So it’s probably not the application, but the way the HOSTS file works. I may be wrong.

As for whether or not you are noticing a slowdown, depending on your system, it may be negligible, but it is happening. You can’t get around the way the HOSTS file works. It’s a non-indexed file that needs to be scanned from the beginning with each lookup.

Even mentions that a HOSTS file over 135kb tends to slow down your machine.

ive decided to not bother with hostsman and i tried to install hosts xpert as well but no probably was the massive dowmload that slowed up the machine?..i just dont know but the machine run perfectly after a system restore.

many thanks.

bye. :-TU

Many thing are true, HeffeD
… well you definitely don’t need to merge many hosts files :slight_smile:

At the same time what is definite as well - there should not be “freezing of the computer” as DARREN.1972 stated

My hosts is ~900KB currently; 30.378 names

I don’t feel a thing re: slowdowns, needless to say about “no freezing(s)”
Sure, I tested without it - the same responsiveness