Host name do not resolve to current ip-address whe using dyndns [Issue Report]

The bug/issue

  1. What you did:
    Created a rule with folowing settings:
    Action: Allow
    Protoco:l TCP or UDP
    Direction: In/Out
    Source address: Type:Host name with host name registerd at dyndns
    Destination Address: Any Address
    Source port: Any
    Destination port: 3389

  2. What actually happened or you actually saw:
    The rule worked until the ip-address the host name resolves to changed. The host name still works for other applications.

  3. What you expected to happen or see:
    I expected the rule to resolve the ip-address behind the host name and use the current ip-address when evaluating the rule.

  4. Have you tried to fix it & what happened:
    Yes. What happend was that I discoverd that the rule do not use the current ip-address when evluating. It seams to use the ip-address that was assigned to the host name when the rule was created.

  5. If its an application compatibility problem have you tried the application fixes here?:

  6. Details & exact version of any application (execpt CIS) involved with download link:

  7. Whether you can make the problem happen again, and if so exact steps to make it happen:
    Steps to recreate:
    1 Create rule that use host name.
    2 Test rule. Evaluated to Allowed
    3 Change the ip-address that the name resolves to.
    4 Test rule. Evaluated to Blocked

  8. Any other information (eg your guess regarding the cause, with reasons):
    By testing and updating/re-save the rule while watching the changes of the ip-address behind the host name. I have come to the conclusion that the Host name option works like entering a static ip-address.
    The ip-address behind the Host name seams to be resolved and cached/stored when the rule is created and not updated after the save.
    As long as the Host name resolves to the same ip-address as when the rule was saved the rule works as expected. When the ip-address change the rule stops working directly afterwards.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:

  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:

  3. A CIS config report or file.
    Do not know where to find. Please advise.

  4. Crash or freeze dump file:

  5. Screenshot of More~About page. Can be used instead of typed product and AV database version.

Your set-up

  1. CIS version, AV database version & configuration used:
    COMODO Firewall 5.5.195786.1383

  2. a) Have you updated (without uninstall) from CIS 3 or 4:

  3. a) Have you imported a config from a previous version of CIS:

  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):

  5. Defense+, Sandbox, Firewall & AV security levels: D+= Disableld , Sandbox= Disabled, Firewall = Safe Mode, AV =

  6. OS version, service pack, number of bits, UAC setting, & account type:
    Windows XP Sp3, 32, Na, Administrator

  7. Other security and utility software installed:
    Avast anti virus

  8. Virtual machine used (Please do NOT use Virtual box):

Did you make this rule for an application or is it in Global Rules?

If you want to make an application rule for a port for both ingoing and outgoing traffic you need to make two separate rules: one for incoming traffic at port 3389 and one for outgoing traffic from port 3389.

The rule for outgoing traffic is often not needed as with standard rulesets outgoing traffic is allowed by default.

It is a global rule.

I have an application rule but that one accepts all.

I also have rules that are identical to the one that fails. And they work without problems. One for my LAN that have a known IP-range and another one for work that have a single static ip-address.

So the only thing that differs between the rules are the way it finds the ip-address that it should allow to pass.

Thank you for your Issue report.

Moved to verified.

Thank you


6 weeks without any feedback.
Is there any interest for this issue/bug?
Or do I have to start looking for another firewall to be able to use Host names in my rules?


Sorry we never receive feedback about any issues report.

Any feedback is usually by PM direct to the member, there are a few replies from Staff in these topics but not often, so it is not just you sorry than I cannot provide a answer.

I can only suggest you try the latest Beta release to see if the problem is solved.

Sorry I cannot help you more.


Edit added Beta