Horrible to try to remove Comodo

2 days of total misery trying to remove Comodo free firewall / CIS. HORRIBLE. NEVER PUTTING IT BACK. MAY AS WELL BE MALWARE IT IS SO HARD TO REMOVE. And searching internet for help, i find this has been a longstanding problem with comodo for people, yet still not fixed.

crashes, system restores, comodo uninstallers, 3rd party uninstallers, regedit, attempted reinstalls, etc. all to try to get this BSODDING HORRORWARE off my win 7 64bit computer.

Not to mention, to install Firewall 10, supposedly “firewall”, not the whole CIS, it tries to get many other things installed also. NO. But it would not even install after multiple attempts, probably because the 8.4, that claimed it was all up to date, would not uninstall properly.

So it is finally off and must stay off! Not putting it on my new win 10 computer.

It is a known issue apparently for a long time, yet you still dont make it uninstallable? And then you try to dump on bloatware when someone tries to just get a “firewall”? :-TD :-TD :-TD

I had an older version that thought I uninstalled. I tried installing the latest free version, and I keep getting the message "To proceed with installation you must uninstall old Comodo Firewall/Internet Security. As it cannot be done by Comodo Internet Security. Please uninstall this old software manually and restart Comodo Internet Security. It is not showing in Control Panel. I give up. I will try another internet security program. Then when I tried to get help from Geek Buddy, they messed up my internet connection. I had to do a system restore.

Xnd, sorry to hear about your difficulties uninstalling CIS.

It’s impossible to tell what had been causing it. Usually running the clean up tool in safe mode will do the trick but that’s water under the bridge. I would love to have helped with uninstalling and handling the pitfalls that arose in your situation.

mthomas771. You could try running Windows Installer CleanUp Utility which is a step in Most Effective Way to Reinstall/Update CIS to Avoid/Fix Problems. Could you start a topic in Install / Setup / Configuration Help - CIS if the problem persists. We will then take a closer look at your problem.

I wanna share something with you guys.
Recentrly I removed CFW 8.4 to install the new CFW 10. Before uninstalling CFW 8.4 I switched off my wifi card, so basically I was offline.
Like this the uninstallation process went smoothly.

So, I’m just wondering, maybe the FW driver can’t be easily uninstalled if the wifi card is active, probably because the driver will be active as well.
If that’s true, it would be advisable to switch off any wifi or lan card before uninstalling CFW/CIS

Hi Jon,

In general, that’s a sign of registry corruption (bad registry permissions). Most likely, you will experience problems with installers/uninstallers.
You’ll need to reset registry permissions to default.

Hope it helps.