Horrible network performance (3.0.19 x32) [FIXED]

Updated to this (3.0.19) version (from 3.0.18): network performance totally down the drain after the update.
Went from an average of 85Mbps down to an average of 10Mbps.

Since Comodo was the only thing that had changed, I suspected it from the start, but just to be sure, I tried:
rebooting - updating network drivers (marvell) - changing network and hard disk parameters - some less important stuff too

Nothing helped, disabled both the firewall and defence+ in the comodo control panel, no luck, still no performance.

Uninstalled the whole lot, BAM, network performance back to 85Mbps…
I’d say there’s something nasty in this build that hampers with throughput and ping.

After this ‘disaster’, I reinstalled comodo again, a clean fresh install, making sure, no lingering files/registry entries remained from the previous install and …

network performance back down the drain again. :frowning:

I contacted a friend of mine who recently updated to this same version and he too has very bad network throughput now, though better than mine still, he manages to get up to 30Mpbs (he’s using a combination of xp sp2 32 bit and vista home premium 32 bit pc’s). I suggest you all check this, it would be very strange if we were the only ones affected by this.

Edit:
I can positively guarantee that this is a 3.0.19 issue, I reinstalled 3.0.18 and network performance is back up to spec.

On thing I might mention still: Comodo firewall does affect network performance negatively, even with other versions than this 3.0.19 horror. Without Comodo firewall installed, I get 91Mbps, with comodo 3.0.18 I get 79Mbps (and 3.0.19 only manages to get to 10Mbps) on the same filetransfer. 80Mbps I can live with (instead of the quite efficient 90Mbps), 10Mbps is simply horrible (heck, my internet connection is faster than that), I may as well get me a wireless 802.11b card. :o

The throughput tests above were on a 100Mbps cabled network btw, via a linksys rackmount switch, so the equipment is a-ok.

Additional info:

  1. cpu: intel e6420
  2. os: windows xp sp2 fully updated (32-bit)
  3. running security apps: nod32 v. 3 (fully updated)
  4. connect to a second pc (also running xp sp2 32 bit), copy any file via explorer
  5. update driver etc. (see above)
  6. default settings
  7. using admin account

Upon reinstall of 3.0.18 the problem is gone, so it definately seems to be a 3.0.19 bug.

Hi,

Please make sure windows firewall is disabled, shut down nod32 with its service(s), uncheck everything under firewall/advanced/attack detection settings.

I had the same network problem too! But I managed to fix it with complete clean install of CFP 3.0.19…

Same slooow network problem, no change if I disabled NOD32 or anything else of secure programs.
Downgraded to v3.0.18.309 and then it works flawless again. As before.

Hi,

Same here, my network performance is extremely slow after upgrading to 3.0.19.318. To test, I did a quick system restore to yesterday before the upgrade (nothing else had been installed since) and network performance was back to normal. I just installed the update again and network is back to extremely slow. Before the update I was able to move large files at ~90Mbs, with the update I’m lucky if I get ~10Mbps. Shuting down the firewall does not help or disabling as suggested also does not help. I don’t have Windows FW enabled either.

I’m going to try completely removing Comodo Firewall and installing the latest version clean to see if that helps. Definitely something wrong with the upgrade though.

Ditto!

Same problem my network performance is slow. From 60 mb to 14mb after updating to 3.0.19.318.
I have Marvell Yukon 88e8056 gigabit ethernet controller.
Now I will test to uninstall and make a clean install to see if the problem will go away.

When I uninstalled Comodo firewall , the speed was back 60mb.
When I installed a clean 3.0.19x32 the speed when back to 14 mb.

Will SDED please explain why this topic has been moved to Help from Bug Reports?

Severe performance issues are bugs and I can see no resolution in any thread so far.

If a clean install DOES resolve the problem, it is only a workaround, the bug still exists somewhere, even if it is only in the updater process.

I too have the same problem. Updated not a clean install. If I Disable the connection and re-enable the status sticks at Acquiring a Network Address, although I do have a connection with a Lan address.

Off Topic, the updater method does not include the new default rules. What is the point of having an updater process if it doesn’t function correctly.

I will now run an un-install and re-install.

Regards, Dave

I can confirm this, too. After updating to 3.0.19 the network performance dropped to 10mbit! :cry:

My System:
Windows XP SP2
AMD 64 X2 4200+
3 GB Memory

Same thing here. Have been pulling my hair off. ???

Addendum: Seems to be some problem in firewall driver as the network performance is s-l-o-w even after disabling firewall or should I disable Defense+ too ?

Same problem here…
I tried uninstalling Comodo Firewall and reinstalling from scratch, but the problem remains…

My Outlook PST file is now horribly slow, it takes ages to save a 10kb file on the network, etc…

I think that Comodo FW is a great product, but I will now wait before updating : a couple of months ago, there was a problem with the update (settings and rules were lost), now the network is sloooooow. I though updates were not beta versions… 88)

How can I revert to the previous version ?

Same problem here. My network performance dropped to about 10% of normal speed after the latest Comodo Firewall update. Disabling the firewall didn’t have any effect, but uninstalling it has restored my normal performance.

Operating system is XP Pro 32 bit, network interface is on-board nForce 550.

Topic was moved to help because it is the highest traffic area and gets the most suggestions on how to fix the problem as well as comments from others with the sqme problem. If you have enough information already, you can fill out the bug report form in that section so that the developers can reproduce and fix it. Reference this thread in your posting there.

Same prob here…

Seems like the problem occurs in several system configurations. Please help us gather some information. First, try an internet speed test to get network performance in a common setting. I use http://lax.speedtest.dslextreme.com/speed_web100.php to get the raw speed information and statistics attached. Please see how this compares to your advertised speed; mine is just about right. Check the statistics and other information to see if anything seems unusual. Let us know the results and how they compare to your full internet rate.
Then go to http://www.wireshark.org/ and download a free copy of the Wireshark protocol analyzer. Run your network logon and then networking benchmarks against it and look for a lot of connection failures, nacks, delays and repeats of connection tries. I have attached a copy of the startup of a Wireshark run, showing getting the LAN IP address for a NIC via DHCP. Post a section of your results if something looks suspicious, like delay times or repeated nacks. We are looking for some sort of common issue that can be turned into a bug report, since most users can’t repeat the problem.
BTW, if you get stuck at “acquiring a network address” but actually have a valid LAN address, that is a well known bug in XP SP2. :wink:
I don’t have the problem with Vista Ultimate, so can’t do any self diagnosis. :slight_smile:

[attachment deleted by admin]

Hello,

I have been using Comodo Firewall Pro for about 2 Weeks now, without problems. Today, I received an update of the firewall software, and since today, my X-Box connection to my PC is incredibly slow. I just wanted to inform you about that, and ask if other users have the same problem.

Some details concerning this topic: I have an “old” X-Box system, which i use to play video and music files from my PC, which is protected by Comodo Firewall. the connection is done via SMB-Shares on my PC. All is connected on a class-C subnet, 100MBit ethernet.
Normally, this is very fast and fluent, but since I installed the latest Comodo Firewall update, I have stuttering and slowdowns whenever I connect to my PC from the XBox and try to play a video.

I can reproduce this. It doesn’t help to disable the firewall, but it helped uninstalling it. When I reinstal it, and perform the update, the slowdowns occur again.

maybe this helps the developers to fix the problem, as long as it persists, I canot use this fine product.

Thanks.

cu,

Jackie

You also can use http://www.speedtest.net/… though for me results are different:
lax.speedtest.dslextreme.com download = 350 kb/s
upload = 250 kb/s

speedtest.net download = 500 kb/s
upload = 490 kb/s
???

Sure, use whatever one is closest. You may just be further away and get more network congestion with one or the other. Usually the comments tell you if there was congestion, and you may need to repeat a test a few times to get a good speed run. But if you are using the same NIC and router, would like to eliminate that link as one source of problems. Another good tool that may offer some insights is Wallwatcher (http://sonic.net/wallwatcher/ but it doesn’t work with all routers/firmware-must support external logging of the router traffic. :slight_smile:

Ed, like always there are things worth to learn from you :slight_smile:
thanks

Same problem here ;_; fix?