Horrible experience after update to Comodo 7

About 24 hours ago, I accepted an automatic update of my Comodo firewall. Perhaps I should have checked the net for the many problem reports that other users are writing about this update, but I never had a problem with Comodo updates, and so I did not. Consequently, I spent most of the last 24 hours trying to get my computer and software back into a workable condition again, with only partial success. My productivity is approaching zero due to all this hassle, and I’m currently considering changing to a different product. Before doing that, I would like to give a detailed problem report, hoping that some official (or experienced user) might be able to help.

First, here’s my usage scenario:

I’m using Comodo since 2006 and usually keep it up to date. I’m on Windows 7 64-bit, on a machine with an i5 2500K CPU and 8 GB RAM, so performance shouldn’t be an issue. I have firewall and Defense+ (now HIPS?) set to “Safe mode”, and sandbox disabled.

I am a games collector, and have about 1500 games installed concurrently on my machine. Whenever I install a new game, I set the firewall to “Training” until the game has the permissions it needs. This has led to very long lists of trusted programs, which might be related to the problems I’m currently having. I do not use the “Game Mode” because I’m afraid of forgetting to switch it off - the only time I ever contracted a virus/trojan in 30 years of operating computers was when I browsed a malicious website while Comodo was still set to “Game Mode”. Since then, I prefer to create individual rules for each game.

Second, the problems I’m having:

The update immediately caused problems, though I was able to solve some over time. I have emboldened the ones that are still unsolved and that are making me consider switching away from Comodo.

  1. The installer tried to persuade me to install additional software. I do not appreciate this way of putting additional software on users’ machines. Thankfully there was a way to opt out, though it wasn’t terribly obvious. Implementing this as an opt-in feature would have been more respectful to your users, imho.

  2. The PC froze completely during startup, after showing the desktop, while loading the autorun programs. There was no information what was going on. Not even the mouse pointer responded. Various resets didn’t help, going into Safe Mode made the computer start correctly, but the problem reappeared on the next regular boot. The solution was, ironically, to wait for a full 10 minutes. After that, the machine magically unfroze.

  3. Annoying ads were suddenly and frequently displayed on my desktop. I found a setting to switch them off, but again it wasn’t terribly obvious what the setting meant, since “messages from Comodo server” could have been something useful as well. After changing the setting, Comodo froze for several minutes. I exited and restarted Comodo, and the setting was back to its default “switched on” state, so I had to change it again.

  4. An annoying desktop widget suddenly appeared, with no explanation what it might be useful for. It only seemed to contain redundant links to the main UI, plus some links to browsers and social media services which I don’t even use much. I found a setting to switch that widget off as well.

  5. The main Comodo window has switched to a click-intensive UI that hides a lot of information behind links or tabs, and that seems very inefficient to me. Probably nothing that will be changed, but I don’t understand the reasons to change to this new UI in the first place.

  6. To switch Comodo settings, I usually right-click on the tray icon and click the desired setting in the context menu. However, this process is now unreliable. Often, I will click the desired setting, the popup menu will go away, but when I access it again to check, it shows me that me still the previous setting, i.e. the change that I made has not registered. This makes it difficult to be certain in which state Comodo currently even is, I practically always have to re-check my settings. This may be related to having the Comodo window open and/or to Comodo freezing after changing something.

  7. Most of my installed software did not work any more. I had to set the firewall and HIPS into training mode and start every single one of the programs that I regularly use, to get them going again. There were no such problems before the update. I will probably have to repeat that procedure for pretty much every other software installed on my PC, which is highly annoying.

  8. I apparently cannot install new programs with Comodo 7 running. Or at least it’s an incredible hassle. For example, I tried to install the game “FTL Advanced Edition” through its GOG installer - usually a simple and reliable process that works without problems after telling Comodo to treat the installer as, well, an installer. Not any more, though. The process now “works” like this:

  • I start the installer, Comodo informs me about access to protected parts of the system. I tell Comodo to treat the program as an installer and to remember that decision. The Comodo popup closes. The installer does not continue, and after a long time it quits with an “error 5” (file access problems)
  • I start the installer again, Comodo again informs me about access to protected parts of the system (though different than before). I again tell Comodo to treat the program as an installer. Again, the popup closes, and the installer does not continue, after a long time it quits with an error.
  • I start the installer for the third time. This time Comodo finally lets it through, and I am able to install the game. When I run the game, I see a white window with “(not responding)” in the title.
  • At this point, more than 30 minutes have passed, and I decide that Comodo is putting me through way too much hassle for playing a simple game. I switch Comodo off completely and reactivate the Windows firewall. Magically, the game works now, and installing other games works as well.
  1. Most of my games do not work any more. That’s an estimated 1000+ installed games that worked flawlessly before and that have stopped doing so after the update to Comodo7. I am getting lots of popups about things like registry key changes, or connections to the Internet, which all should have been dealt with weeks or months ago when I installed the games. Examples:
  • Warlock 2, a game that worked fine just an hour before applying the Comodo update, refused to start. I had to put it through “Training mode” again to get it working.
  • Pid, a randomly selected game that I hadn’t run for a long time, refuses to run as well. Even putting it through “Training Mode” does not help, it just produces an “error 82” on Steam. It did work last time I played it.
  • Path of Exile, an online action RPG, was suddenly unable to connect to its server. Instead of letting the connection through (as it should), Comodo popped up a warning about outbound traffic again. I told it to allow the connection and to remember that setting. However, the game told me that it was still unable to connect to its server. Further attempts to connect yielded the same error message from the game, and Comodo didn’t even show a popup any more. Apparently Comodo thought that it had handled that request while still blocking it. I had to restart the game two more times to get that working. I never had connection problems with this game before, and I played frequently in the past two months.
  • All three games (and many more) magically work after switching off Comodo and reverting to the Windows firewall. Which, to be honest, is a very tempting solution after spending 24 hours with the issues caused by Comodo’s update, and still having 1000+ games that just won’t work any more.

Third, my request for help

  1. What can I do to fix problems 8 and 9 (and possibly 7)?

  2. Is there a better way of using Comodo in the usage scenario that I described above? I’m suspecting that perhaps Comodo has trouble dealing with rules for 1500+ programs. If it iterates through all those rules, and if version 7 perhaps takes a bit more time doing so than version 6, then this might explain why I am having so many problems with Comodo becoming unresponsive and decisions apparently not being applied immediately.

Any help is appreciated. Please note that I vastly appreciate answers that address the details, over boilerplate replies. After already losing a lot of valuable time to these problems, I spent another hour trying to produce a detailed and useful error report, and it would be nice to not have done so in vain. I’m of course willing to provide further information if requested.

i also had problems and i also thoght its because of the old rules after the update
i did install every thing new and still had problems with the new version
after reading some postings here i would say export your rules and downgrade
or search for a working solution :wink:

Post a bug report and hopefully this will get fixed for you. Comodo Forum

I’ve had pretty well the same issues as Psyringe and have now resorted to using Windows firewall too, never ever though that would happen !

I’ll monitor these forums for a while and see if anything changes, but in the meantime I’m looking for a replacement, again, never though that would happen after using Comodo for years. :frowning:

Wow, that’s a very similar setup to me. I also had an absolute nightmare yesterday after the update too. I had previously attributed most of it to a windows update but after reading your post it was probably comodo behind most of it. It was messing with the rendering of save dialogs, all kinds of things.

Like you said Comodo has been a valuable tool to me that does it’s job quietly and unobtrusively until yesterday. It went from a functional, intuitive interface to one with menus hidden behind words and a general pain in the ■■■■ to use.

I can’t get it stop messing with firefox, delaying it’s startup.

I’m afraid I haven’t got any words of wisdom for you but I do feel your pain. I’ve probably got the old installer somewhere, maybe we should uninstall the new version and go back to the old one that worked?

I meant to say, those ‘stealth’ installs of other software was pretty low. I hate that kind of thing. Luckily we’re the kind of people who check these things but most won’t and that’s what comodo are counting on. Seems pretty underhanded to me.
I’ve gone from rating and recommending a piece of software to pretty much hating it in one update.

Good job comodo! :slight_smile:

I’ve had most of the problems you had up to problem #7, including the freeze on first time I started the new version after reboot. I hard reset the PC the only slowdown I had since was the strangely long time it took for it to let me click the pop-up “new software trying to access the internet, what do you want me to do?”-dialogue first time it popped up. It just sat there for a while and any time I would try to hover mouse over it for first half a minute after it popped it would just show me hourglass and not let me click the answer.
I did not experience any of the other problems. I tried several games, including path of exile, and they all work fine after that. Seems like update makes firewall to do something internal that takes a long while.

I suspect that update corrupted or incorrectly imported your ruleset. You will probably have to purge and do a clean install of the firewall. Also I recommend disabling all other services except firewall (i.e. antivirus and the protector service). Comodo antivirus product is the complete opposite of the firewall, a very shoddy and resource-intensive piece of software, and the blocker doesn’t really do anything significant that UAC doesn’t do already. But it causes severe problems for installers.

Try a clean reinstall. I suspect you’ll have to rebuild your ruleset from the beginning now, unless you have a recent backup somewhere. That said, if your ruleset had that many entries, perhaps that is a good opportunity to clean it up a bit?

Well I’ve done a clean install twice, and also cleared out all references to Comodo from the registry so there are no old rules to influence the new install, same result, Comodo Firewall is pretty well useless for me now.

Hopefully Comodo will clean up this version soon, if not I’ll have to look into another firewall besides the Windows one.

found any good stuff? 88)

I just had to register here to say that my experience with the Comodo 7 auto update has also been a nightmare and I have spent the last 15 hours trying to recover from this monster. I have no idea why Comodo, a brand I have used happily and consistently for more than 7 years, decided to completely ■■■■■ my satisfaction with their product, but they did. I tried valiantly to live with this new version, thinking that a learning curve was all that was necessary, but after a week I have had all I can stand. I uninstalled this version and am now looking for a new firewall product. If anyone finds a good one please let me know, I really need something better than Norton Smart Firewall shudder.

Sounds like an installation problem.

Prefer clean installs. Its not that much trouble to make a new rule set.

Guess you haven’t read where I and others have done clean installs, makes no difference.

When reinstalling CIS please follow Most Effective Way to Reinstall CIS to Avoid/Fix Problems by my colleague Chiron. It will provide a reliable and clean starting point.

If that does not fix it then it is good practice to see if other security programs that run in the background are of influece.

Please don’t hijack another person’s topic. Would you kindly consider to start your own topic for your problem? That way this topic won’t ago astray and your problem will get the attention it deserves.

Did Comodo force itself upon you? Dunno about post v5.x - and can’t speak for v6.x - but my experience is that ANY updates is explicitly manual.

The electrum pressed latinum Ferengi Rule of Acquisition is when notified of updates to any application, always investigate what the update entails. If the update is from v0.9 to v0.95, then that’s prolly a bunch of bug-fixes. If the update entails migrating to v1.01, that’s a major version change. One should always check the support forums to get one’s pulse on the products thumb about current issues. Now if the version changes to v1.10, that’s an intermediate version update, and usually will incorporate significant bug-fixes in addition to enhanced functionality. If the update intimates migrating from v1.5 to v2.05, that’s not an update; that’s an upgrade.

ANY upgrade by necessity should obviate the need to establish whatever backups of configuration, preferences and / or system state as may be demanded so as to comply with the computer user-Supreme Being’s edict: roll-the-stinkin’-thing-back-to-when-it-last-work! Make it so, NOW!

All I know is the prollem is with v7.0. Notice that ZERO at the end? The last version was v6.3.XXXXXXXXXXXXXXXXX.something. This is a major version upgrade. You can’t color me ‘surprised’ there are issues with certain platforms and configurations.

Perhaps it is Micro$oft’s product release model that Comodo should follow; WinXP SP1 was flawless (and upgrading from Win95 to WinXP was a no-brainer utterly devoid of consequence).


Comodo Fanboi Extraoirdinair
(Don’t Bad-mouth my Comodo)

I used Comodo for a year or so. It was all OK until the latest update, where the PrivDog automatically installed, no say if i wanted or not. It became part of the system. My computer started freezing ALL the time, regardless which browser i used. I got Firefox, and Chrome. Chrome got completely disabled useless, i couldn’t even use it any longer.Firefox worked but the constant long freezes were unbelievable annoying. If i pay for the program i should have the say what i will install. To watch advertisements, provided by Comodo is a conflict of interest.So i have decided to put an end to this a couple of months in to it. I made a great attempt to uninstall the program. Well it was not as simple as I that. First it was taken like an hour to uninstall in the add and remove programs. But it nowhere close to real uninstalled as left hundreds of entries in the registry. In the "services folder " i had 4 Comodo service still alive after it should have been uninstalled and deleted. So as i had 3 entries in the start up folder still live after it supposed to be uninstalled. So with a program I have I wanted to delete them on reboot as i that those files has no use anymore anyway. Boy i got the blue screen on the way back.So one of those files was attached to the boot menu. Windows regular start up repair couldn’t fix it. Luckily i had an other boot menu fix program…and guess what, that didn’t worked either.But That program was able to locate the system restore “snapshot” and the computer was up and running , as i that i will loose everything as I got to reinstall everything from scratch. This time I was smarter, i figured the worst happens I use the "snapshot again, so I have attacked the entries scientifically.

I have disabled all the Comodo entries in the Services menu. Now i rebooted to see what will happen. No crash. Regedit …search… Comodo…oh boy an hour later all the 1001 entries were deleted. After this I had the files deleted from the start up folder menu, (delete on reboot again) and this time it didn’t crashed. What ever they did the program got so heavy it crashed under its own weight. To collect money from advertisers and paid programs gets the same ads is something else in the name of protecting my health. i don’t believe so for a minute my computer was the only with the exact same issues. So as i have never seen in my 14th years of using computers how a program would take an hour to uninstall and leaves everything beyond in the registry… So as to crash a computer, and if I didn’t have the boot menu repair program, what actually didn’t work rather the back up “system snapshot” from the rescue disk I would of had to reinstall all over. Comodo will never be installed ever…i am really disappointed. And to willfully force an advertisement program with no way to opt out is outrages. I suspect the freezes were the byproduct of Goggle ads and Comodo ads clashes. Both were trying to load in the same time. The computer didn’t know which to load in to the webpage so it got hanged! Again this is the explanation i can think of. It had to be one ad or the other , as we have only so much room for the ad space.

Sorry to hear you had such a bad experience. Something truely went wrong. If you are reinstalling CIS please follow Most Effective Way to Reinstall CIS to Avoid/Fix Problems by my colleague Chiron.

It will not only describe how to get rid off possible left overs of CIS but also possible remnants of previously installed security program (the latter may cause all sorts of strange effects possibly including the symptoms you have witnessed). Chiron’s guide will provide a reliable and clean starting point.