Home Group Problem

DSL modem feeding a LinkSys router; one computer using Windows 7 Home Premium 32-bit, the other 64-bit.

A few days ago, I enabled wireless on the router, and both computers can access the Internet.

I then started working on setting up a HomeGroup, to share files, printers, etc, and that is where I’ve encountered problems, namely that the two computers won’t talk to each other.

I followed the fine step-by-step HomegGoup setup instructions I found under the rubric of “Ultimate Troubleshooting Guide for Windows 7 Homegroup.” In addition, based on information on the Comodo forums, I created a Trusted Network at 192.168.1.1 and 255.255.255.0, the first set being the LinkSys Router.

Having read that Comodo might be a problem, the last test I conducted was to disable Comodo in the Windows startup group on both computers, rebooted, and tried HomeGroup again. Both computers show that they are members of a HomeGroup, using the same password, but even with Comodo disabled–or so I thought–the two computers won’t talk to each other.

With Comdo supposedly disabled, however, the Windows Action Center on both computers shows that both the Windows Fire Wall and Comodo Firewall are active.

I thought that the Comodo Trusted Network I had set up would allow inter-computer communications, and I also thought that disabling Comodo and restarting would allow HomeGroup to work.

Alas, so far, no luck; assistance gladly accepted.I obviously don’t know that Comodo is causing the problem, but this forum would seem to be a likely place to try to prove or disprove that. Perhaps I set up the Trusted Network incorrectly, for example, or whatever it is I need to do to get things working properly might come from people here.

Setting up a Homegroup can be a bit of a challenge with any third-party security application, however, with a few ‘tweaks’ it’s easy enough.

I followed the fine step-by-step HomegGoup setup instructions I found under the rubric of "Ultimate Troubleshooting Guide for Windows 7 Homegroup." In addition, based on information on the Comodo forums, I created a Trusted Network at 192.168.1.1 and 255.255.255.0, the first set being the LinkSys Router.

Creating a trusted network is a good first step.

Having read that Comodo might be a problem,

The job of a firewall is to keep unsolicited packets out, unless you tell it otherwise. CIS is just doing it’s job.

the last test I conducted was to disable Comodo in the Windows startup group on both computers, rebooted, and tried HomeGroup again. Both computers show that they are members of a HomeGroup, using the same password, but even with Comodo disabled--or so I thought--the two computers won't talk to each other.[

To disable the firewall, select the icon in the system tray and choose firewall/disable.

With Comdo supposedly disabled, however, the Windows Action Center on both computers shows that both the Windows Fire Wall and Comodo Firewall are active.

Unfortunately, this seems to be a problem for some people. Here’s an example.

I thought that the Comodo Trusted Network I had set up would allow inter-computer communications, and I also thought that disabling Comodo and restarting would allow HomeGroup to work.

In part…

For Homegroup communication, you need to make sure svchost and the system process have Application rules that allow both outbound and inbound communication between all respective LAN nodes. You also need to ensure you have the requisite ports open in Global rules.

As a start, run Stealth Ports Wizard with the first option:

Define a new trusted network and make my ports stealth for everyone else

This will create the basic file/printer sharing rules and create Global rules to Allow the inbound/outbound LAN traffic. In addition, In Application rules, make sure svchost has similar rules to those created for the system process.

If you need media streaming/sharing you need a little more…

Radaghast: Thank you for your lengthy and informative reply, which I’ve printed out so that I can refer to it as I continue my search for solutions.

Meanwhile, another question: Am I correct in understanding that the router has to support IPv6? If so, an on-line search a few minutes would seem to indicate that a Linksys WRT54GL does not do so.

Depends on what you mean by support. if you’re just taking about LAN based connectivity, then the router is just a switch. However, the Linksys WRT54GL is easy enough to upgrade to far better firmware that fully supports IPv6, such as Tomato also look at: LinksysInfo.org

In my readings on-line about HomeGroup, more than once I came across a statement that the router must “support” IPv6.

Given that, as must be obvious, I am truly an expert on this entire matter, well, I don’t even know what “support IPv6” means; I only know what I had read (and don’t even have any URLs to such information.)

In my earlier-today looking into this, I did see some references to Tomato; I’ll follow up on that as I continue to confuse the entire known and unknown worlds, on the grounds that, eventually, my two computers will talk to each other, with the help of persons such as you.

IPv6 is the replacement for the currently deployed, but creaking at the seams IPv4 protocol suite. IPv4 is based on a 24 bit numbering system, which is typically represented in decimal - 192.168.1.1 - IPv6 is based on a 128 bit numbering system and is typically represented in hex - 2001:210:1f24:1a47:8662:8014:1ca1:9f0. Amongst many other features, IPv6 gives us a great deal more addresses to play with.

Windows 7 has native support for IPv4 and IPv6 and Homegroups have dependencies on the IPv6 protocol stack, however, if all the nodes in your Homegroup are on the LAN, having IPv6 support in the router is not mandatory. If some nodes of the Homegroup are outside the LAN and need to communicate through the router, the router needs to support IPv6. Whilst it’s true that more and more router vendors are adding IPv6 support to their product range, a great many routers produced in the last few years still lack this support. Enter the third-party firmware suppliers.

There are several well known firmware packages available for various router manufactures products so it’s worth looking at the individual offerings to see if your router is supported. With a Linksys router, the forums I linked to above are a good place to start and I whole heartedly recommend Tomato. I’ve been using this for a long time now and the various builders update and extend their offerings quite frequently. It’s also very easy to install.

Once again, many thanks. I’ll install Tomato, to replace the Linksys software that does not even recognize Firefox 8.x. I chatted with Linksys about this; their attitude was that they’re not going to bother to update their software.

Once I’ve found time to download and install Tomato, I’m sure I’ll be back to pester you further. I have no LAN, just the wireless two-computer network, and given what I’ve been able to find on-line, I’m rather certain that the Linksys router does not support IPv6, and if that is so, then surely at least part of the problem will be solved.

As previously threatened, I have returned.

  1. I installed Tomato a short while ago; the only problem is that apparently it does not like Firefox 8.0, but works fine in IE 8. I’ve not tested to see if perhaps one of my FF extensions is the problem (that is, under FF, I don’t see anything useful, but shall continue to fiddle with this.) I unplugged and restarted the router, just to be certain that nothing involved with installing Tomato had not fully registered.

  2. Some progress, but Homegroup is still not working; the following entries are true for both computers:

a. If I open Explorer and click on Homegroup, it says that there are no other people in the Homegroup.

b. If I then click on View Home Group Settings, it says that the computer belongs to a home group.

c. If I change a home group setting, I get a notification that the computer is sharing files, etc, with a warning not to shut down the computer until the sharing is completed.

  1. I have run the Homegroup trouble shooter, which refreshed the home group settings on both computers.

I continue to be stumped: It would seem that my Homegroup both does not have anyone on it and yet it does, and I don’t know what to do next, so further assistance would certainly be welcome.

Shortly after posting this totally brilliant, uh, er, oh, okay, simple message, I enabled javascript for Tomato in Firefox, which fixed the minor malady.

The frustration continues: It occurred to me that the problem might be that each computer has only one user account, each with the same name. Thus, I went to the older (32-bit) computer and created a second account, then switched to that account.

HomeGroup continues to insist that, although each computer is part of a home group, there are no other people in the group.

Mega Sigh.

(Oh, yes, exiting Comodo on both computers does not fix anything, Mega Sigh The Second.)

The error message is usually caused when the settings for the shared Homegroup objects are not set correctly. Under Network and Sharing Centre/Choose Homegroup and Sharing Options have you checked the relevant boxes on both computers? As an aside, it can also take several minutes for Homegroup members to recognise one another…

As I thought, the same boxes are checked on both computers.

After at least thirty minutes, when I click on Start, John, Homegroup, I continue to see “There are no other people in the home group,” and I get the same information on the other computer, even when I switch to the account I created yesterday (and, yes, the homegroup appears in that account as well as the original account.)

Very frustrating, as I simply have no idea as to how to fix this, nor have I been able to find any relevant information on-line. Please do NOT take that to mean that I do not greatly appreciate your assistance, far from it.

Returning to my first post, I think it’s worth checking you’ve created the necessary firewall rules. The images below show a fairly basic firewall configuration for the main processes involved in Homegroup communication. This could simplified still further, by simply creating In/Out rules to and from everywhere.

To explain the rules a little:

The Network Zones contain two entries:

  1. Loopback Zone - 127.0.0.1 is the IPv4 loopback address and ::1 is the IPv6 equivalent.
  2. LAN - The IP blocks used on the LAN 192.168.1.0/255.255.255.0 is the IPv4 range and fe80::/10 is the IPv6 Link Local address block.

The Network Security Policy has rules for the three key processes for Homegroups:

  1. wmpnetwk.exe - Windows Media Player Network Sharing Service

The image only shows rules for outbound SSDP, however, to fully utilise media streaming you’ll need additional inbound rules, as well as rules for the other Media Player services. These two rules should be enough to get a Homegroup working.

  1. svchost.exe - Generic host process

This is fundamental to Homegroup functionality and must be able to both send and receive between nodes in a Homegroup. The easiest way to achieve this is to create a Network Zone with the appropriate address blocks and then use that zone to create simple In/Out rules. For simplicity, the rules I’ve created just contain local devices, hence the LAN designator.

In addition, you’ll need to allow some multicasts for things like UPnP (UDP port 1900), Network Discovery (UDP port 3702) and LLMNR (Link-local Multicast Name Resolution - UDP port 5355). Of course, you’ll also need rules for usual svchost operation, such as DNS, DHCP, Windows updates etc.

  1. System Process.

This is the key service used in file and printer sharing and with Homegroups it plays a part in media streaming. As with svchost, the easiest way to deal with the requirements for this process, is to use a Network Zone that encompasses the entire range of addresses used by the Homegroup and to simply allow full inbound/outbound communication between these nodes. You’ll probably also require a rule for IGMP.

Edit: Just a thought, if you haven’t seen it already, I suggest reading through HomeGroup and Firewall Interaction It deals primarily with Windows firewall but the information is useful.

[attachment deleted by admin]

Hmm, I wonder what language you are writing in, none of this being anything with which I’m familiar.

Oh well, I had downloaded the Interaction file a few days ago, then forgotten it, so it is now printed. I have a feeling that I will understand less of this than a medieval manuscript, but shall nonetheless make a valiant effort to read and possibly even understand at least some of the document; if I do manage to comprehend anything, I’ll even attempt to apply that information to my two computers in my ongoing battle with the chimera. (One definition thereof is “An imaginary monster made up of grotesquely disparate parts.”)

I’m sorry if this is sounding like the Ancient Greek to which you allude. Still, think of this as your very own struggle. Not, perhaps, on the scale of Troy, but it’s all relative :wink:

Have a read through the document and see where it takes you. As I said, it’s really designed for use with Windows firewall but the basic principles are applicable to any firewall.

Chuckle, chuckle, nice try, but my wife is the classicist, I’m the medievalist, so I was referring more to such extremely useful things as Anglo-Norman, Ye Olde Englishe.

Nonetheless, you were not at all far off, for yes, to me is does rather seem to be Ionic Greek (now there is something truly useful!)

I did take a quick look at the MS document earlier today; maybe I’d better look again to be certain it is not Greek.

On a serious note, yes, I will take some time to try to understand the document.

  1. I have determined that the MS document really is Greek: When printed as a two-sided document, the pages are completely messed up, so that when reading one page, the following page is somewhere else in the document, rather than being the next page.

  2. I have attempted to read the document, despite the pagination problem, and found no assistance there.

  3. The HomeGroup troubleshooter is also of no assistance, despite my having run it several times on both computers. It either claims that there are no problems, or else that it cannot figure out what problems exist.

  4. While I don’t really know what all the readings mean, the Comodo Firewall Active Connections module shows quite a few things listening on 192.168.1.xxx, and in many cases that is also shown as the destination; that is, of course, the router.

  5. I am a complete halt: I have not even one idea of where to turn next to try to get HomeGroups to work.

====
A few minutes later: I just reran the troubleshooter, and then, for the first time, looked at the related report. The only thing it shows is that Comodo is installed, and further down in the report states that Comodo is configured to allow HomeGroups. All other issues tested by the troubleshooter indicate that the issue does not exist, other than something about the user’s manual efforts to fix matters–and I don’t know what manual things I might do.

FIXED!

After posting my previous message here, I Googled “Homegroup Problems.” The very first link gave me the solution, namely that computers in a HomeGroup cannot have the same name.

I renamed the new computer by adding a 1 to its name, rebooted, and found that HomeGroups were working. I just sent a simple test print document from the older computer to the newer, walked through the house to the newer computer, where I found my test document.

It just might have been helpful had the various MS documents, etc., that I’d looked at about HomeGroups bothered to mention this “minor” detail.

How curious. It’s always been the case with Microsoft networking that duplicate names are not allowed on the same segment, however, it also used to be the case that, when one tries to add a PC, with the same name to an existing network, an error message was presented indicating the duplicate name.

I’m glad you’ve managed to fix the problem :slight_smile: let us know if we can be of any further assistance.

Unfortunately, I never got a single instance of any error message that, had it appeared, would have either led me to the solution of the problem, or at least have allowed me to post a message in this thread asking what the error meant and what to do about it.

Had I posted such a message, it is clearly evident that you would have understood the error and quickly provided me with the necessary instructions on how to fix the error.