HIPS prevents file downloads from Firefox


I read a lot of topics on this, still can’t find a solution to the problem.

The problem essentially is this - suddenly Firefox started experiencing issues with saving files - every time I try to download a file (any file, not only executable), a window pops up saying the file can’t be saved to …\AppData\Local\Temp\filename.part (somehow it always saves a file to the temp folder even before asking where to save it). By the way if instead of clicking on a link I choose “Save object as” option Firefox supposedly doesn’t try to save the file to temp dir first so no errors occur.

After some research I found that Comodo CIS can be the source of the problem and sure enough disabling HIPS completely resolves the issue.

I tried deleting both HIPS and firewall rules for Firefox but that didn’t help. Comodo CIS version is, Win 8.1.

Did anyone have this issue? Can you please help me? :slight_smile: Thanks!

I’m having the same issue but so far I haven’t found a solution. Someone mentioned going back to CIS 7 and it fixed the problem. Interestingly they finally upgraded back to CIS 8 and the problem went away. I really don’t want to uninstall though if possible because it takes forever for me to get the software to run the way I want it to on my PC setup.

From a topic with the (almost) same problem:

You can always export and import the CIS settings. That will save you a lot of work indeed…

When reinstalling CIS follow Most Effective Way to Reinstall CIS to Avoid/Fix Problems by my colleague Chiron. It will provide a reliable clean starting point.

Hi, actually I did reinstall Comodo after following the instructions provided (using Revo Etc). AFter it was uninstalled, the Firefox download issue went away but shortly after reinstalling the latest version of Comodo Firewall, the problem returned. I notice that sometimes I can get Firefox to download if I open the download window in a new tab. The strange thing is that it’s mainly exe files that seem to be the issue. Other file types appear to download without an issue.

We may be looking at a bug here. To call it a bug I need to know you removed possible left overs of previously installed security programs as described in Chiron’s guide. Do you have other security programs installed that run in the background alongside CIS?

I’m also seeing this problem with FF 34.0.5 on win7x64 while using the FF download manager. I don’t see that the file extension of the download file makes any difference. I would estimate 90% off the time the download fails. The thing is, is that in FF if I open the download manager and select “retry” on the failed download it has worked 100% of the time. From looking at some FF forums I saw that Comodo seemed to be implicated in at least some cases (I am on I did try a couple downloads with HIPS disabled and they worked, but I haven’t done enough testing to confirm this result. Not really excited about having to do an uninstall/reinstall, but if it does seem like HIPS is the source of my problem will give it a shot.

scott s.

Scott. Do you have another security program that run in the background alongside CIS? Also if had other security programs installed could you please run clean up tools for them. That is to see if there is an influence of possible left overs of them.

These questions are important to determine whether we are looking at a bug.

Okay, it seems I finally managed to resolve this issue. I saved the CIS settings (thanks EricJH) and reinstalled the product. Clean install didn’t cause the issue, so I imported the settings back and the issue returned. As I have the “create rules for signed apps” check-box enabled there are rules for every application. I removed all firefox related rules long ago but that didn’t solve the problem so this time I unchecked the check-box and deleted all HIPS rules and the issue is gone.

I’m sure I didn’t create any HIPS rules recently and I believe this all started after the firewall’s update.