HIPS doesn't check file rating changes immediately [M2098]

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Yes, always.

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: try to run any unrecognized application and got message “Access denied”, that’s right (look at SETUP)
2: change application state to trusted in a rating file list
3: try to run application again and… got the same message, that’s wrong
4: the ability to run the application appears only after some time, about 1.5-5 minutes

One or two sentences explaining what actually happened:
HIPS doesn’t check file rating changes immediately

One or two sentences explaining what you expected to happen:
HIPS should check the actual rating value

If a software compatibility problem have you tried the advice to make programs work with CIS?:
No any compatibility problem

Any software except CIS/OS involved? If so - name, & exact version:
No

Any other information, eg your guess at the cause, how you tried to fix it etc:
The same bug appears then remove trusted application from rating file list. Application (unrecognized now) can be run for 1-5 minutes until HIPS begins to block it.

B. YOUR SETUP
Exact CIS version & configuration:
CIS 10.0.0.6092, proactive security

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
HIPS enabled, safe mode, block any requests w/o alerts; Autosandbox - OFF; Firewall enabled, custom rules mode, block any requests w/o alerts; AV enabled, real-time scanning, no alerts, move to Quarantine

Have you made any other changes to the default config? (egs here.):
Website filtering - OFF, Viruscope - OFF

Have you updated (without uninstall) from CIS 5, 6 or 7?:
Yes, from CIS 8.2
if so, have you tried a clean reinstall - if not please do?:
No

Have you imported a config from a previous version of CIS:
No, only switched configuration to previous
if so, have you tried a standard config - if not please do:
No

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
WinXP SP3, administrator account, no V.Machine

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=No b=No

Thanks for the report. This is already logged in the tracker, but it has been down for last two days and I don’t know the bug number offhand. But once it comes back up I will update it with a link to your post.

Moving to resolved as this should be fixed with Comodo Internet Security v10.0.1.6209. If you still experience this issue please make a reply or PM a board moderator thanks.

It looks like fixed in v10.0.1.6209.