High CPU usage with Comodo FW v5

Since I installed v5 of Comodo I notice very high CPU usage of Comodo. especially when using Facebook and certain games in Facebook.

Both cores (got a dual core) reach almost 100 % CPU. Even when I leave FB the usage remains high. And stays high even after closing Firefox 3.6.10 and then after a few minutes it starts to drop.

I use Win7 64bit and have Avast Home Edition v5.x
If I turn off the webshield service in Avast, well that helps a bit, but then still CPU remains fairly high at around 60-70 %

I never encountered this problem with version 4.x of Comodo. That always ran smoothly with no CPU spikes, and certainly not as high as this.
Before I installed v5 I completely removed version 4, ran the .bat file to clean up the register of remnants of Comodo and even used a registry cleaner after that (and made sure after each step I rebooted)

Any idea why v5 gives these kinda troubles when v4 didn’t?

Nothing changed otherwise on my computer.

I was wondering if there are other users out there who have similar problems?

What Comodo process is burning up your CPU cycles? Cmdagent.exe of cfp.exe?

Does it also happen when you use a different browser? Do you have url’s for the games on FB?

It’s cfp.exe that does it.

I tried with Opera as well since it’s usually a fast browser and very lightweight. But it’s the same with that.

FB games like City of Wonder Log into Facebook is the worst. It always used up a bit more CPU as it is an intense flash based game, but not 2 cores at 100% at least.
Or Mousehunt → Log into Facebook
Or Castle Age → Log into Facebook
Though it seems just the main page on FB itself also causes high CPU spikes as well
here’s a screenshot where u can see I have the normal FB startpage open and on the right on the sidebar gadget u can see how much CPU that uses.


http://media-2.mediahump.com/image/224992/1/0/DT.png

When I use games that CPU usage goes up to 100 % on both cores. I haven’t had these problems with the 4.x version. I am thinking of reverting back to that as v4 never gave me problems.

Here’s also a pic with the taskmanager open so you can see how many CPU cfp.exe is using, just by having FF running, even though it’s minimalized.


http://media-3.mediahump.com/image/224993/1/0/DT2.png

Also the RAM usage on cfp.exe seems more than it was with v4. I don’t think I ever saw cfp.exe use as much as 33 Meg of RAM on v4.

Here’s some more examples, now with Opera


http://media-3.mediahump.com/image/224996/1/0/DT3.png


http://media-1.mediahump.com/image/224997/1/0/DT4.png

As you can see, while playing City of Wonder it’s really bad. But even if I go to regular websites with Opera or FF it keeps having high CPU. At least 50 % and sometimes it spikes up to more than that.

Okay, one more picture with running nothing but the taskmanager. Closed my bittorent client, no open browsers.


http://media-3.mediahump.com/image/224998/1/0/DT5.png

After like 30 seconds or more it drops though, it’s just odd that while nothing is running the CPU still remains this high.
I noticed though, that if I turn off all shields in Avast Home Edition, the problem seems to be gone (even with browser open and surfing). No more CPU spikes. I kinda like Avast, it scores very well in independent AV comparative tests and I would prefer to keep using it. Like I stated, this same version of Avast in combination with Comodo v4 never gave these kind of problems.

/bump

Well since it’s been a few days since last response (which makes me start to believe that nobody actually has a clue on what might be causing this :P) I tried and started thinking a bit outside the box (is there still a job opening? You guys could use me :P).

I started thinking it might be related to the way the new v5 handles logging. I noticed that sometimes (and by that I mean almost everytime there be nothing there at all while logging was set to 20 MB before purging, which is a lot and not sth that would be done after just a day or so) when I opened the log of the firewall, there’d be nothing there. When opening the advanced detail logging under “more” I noticed that Comodo went haywire and started eating up all my CPU. Trying to configure anything there was nearly impossible as the program just seemed to stop reacting. When trying to close the advanced logging it took at least a minute before it would disappear. So I went to the tab to disable logging, and whattaya know, it stopped eating up al my CPU and started to act like it should.
Ofcourse sometimes it would be nice to see the logs just to see what’s happening and if Comodo acts as it sposed to on set rules made for it. So the Comodo team should really work on the logging issue.
I myself find it very strange that no other users even responded to this saying they encountered the same kinda problems. I find it hard to believe that it’s something in my computer, as nothing has changed at all since I used v4 which never seemed to have this problem.
Something made cfp.exe use more CPU than it should, and my findings are that it’s the way the logging is processed.

(P.S. I am missing the “I was born l33t” smiley in that smileys list :P)

Included a screenshot with FF open with 2 tabs and 1 of those is connected to Facebook. And look at the memory print and cpu usage and compare it with my other screenshots. A world of difference now that logging is fully disabled.


http://media-1.mediahump.com/image/225589/1/0/DT6.png

Also when I open the firewall log and then go to the advanced logging by pressing “more” my CPU stays normal, it spikes a little when opening, but after that I can actually press every tab there without problems at all, which confirms that the problem really resides in the logging of firewall and defense+ events. :wink:

Oké, since it’s been very quiet from the part of the mods here, I figured I would let y’all know that I might have fixed the problem.
I still have to monitor it for a few days, but I think I got it fixed.
What I did was actually a very simple solution (one I might have figured the mods even would utter, but alas).
I just reverted back to a system restore point of about a week back. After which Avast always gives kind of a problem but can be fixed by just using the repair option. Now my system seems to be okay.
Avast up and running with all shields up and Comodo has logging enabled again, and so far I do not see any unusual or high CPU spikes. Hope this may also be a solution for those who suffered the same problem.
As for now, I am a happy camper again ^^

i also get the same problem, but i use win xp sp3 not win7 ;D. I think this is because of cloud maybe CMIIW :-, now i try to search alternative free firewall for temporary, if comodo already stable, i will use comodo again ;D

Unfortunately the problem still seems to exist with the way CIS 5 handles logging. I have reverted back to v4 now as that doesn’t give me problems at all

I updated my COMODO yesterday, and encountered the same problem…

I’ve been trying to uninstall/clean install several times, the issue still remains. :-[

so, i reverted back to v4.1 too.

BTW, this issue happens on my laptop which has a Win7 32bit Utimate OS.

I also tried V5 on my PC which has a XP (sp3) OS, and there seems to be no problem.

On both computers, I have installed Comodo and Avast5.0.

Does anybody have any clue?

at first maybe there is no problem, but after several days, the problem will come ;D,

o?

you mean… it will occur on my PC (xp)? I’ll keep an eye on it…

So far, for my laptop (win7), the issue occurs right after installation, and for my PC (xp), everything seems fine for about half a day… We’ll see. ;D

Anyway, hope developers can fix this issue asap.

hfmouse, so basically same setup as me with the sole difference of me running 64bit version of Win7 Ultimate.
Funny thing is, if you disable all shield services (except FileSystem Shield) in Avast 5, the problem seems to be a lot less or even gone. But the problem is not there with all those shields up in v4 of Comodo.
Besides, I really encountered problems with the logging in v5. When I completely disable logging in v5, the problem is gone too, even when Avast has all shields up (well, the problem isn’t totally gone I noticed after a few days, but at least it’s a lot less. CPU sometimes still spiked to 50 % but didn’t stay there too long with logging disabled.)
See what it does for you with shields as mentioned disabled and/or logging disabled.
From my screenshots it must be clear that the problem is not Avast (although maybe in some ways linked), but a problem within the firewall of Comodo itself.
I am running v4 now and have no problems whatsoever. Hope the mods, who have been frightingly quiet up til now (asked 1 question which was answered and since then no reply anymore). Makes one think that despite the evidence of a problem within the firewall, they don’t really know why it does what it does. I guess they figured, since it’s only one person that mentioned this, it might be an isolated problem and must be a problem at local level of this user. That’s why in a way I am glad more people now start mentioning this. Hopefully they might now take it seriously.
Also I keep getting this annoying popup by Comodo that updates are available (ye, duh! v5 I know!!!). I disabled updating feature, but still got the popup. Guess the firewall needs a reset before that takes effect.

I have been quiet but surely kept on eye on the topic.

It sounds like there is a problem with logging when using Avast v5 together with CIS v5.

If you are willing please file a bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!.

Ah well at least it’s comforting to know you kept an eye on it. :wink:

Will file the report. :slight_smile:

hi, for me it is a little bit different. I’ve read your posts above, so when I encountered this issue, I tried to disable logging, however, the cpu usage of cfp.exe remains high. :frowning:

But I do realize there is some link between avast and comodo, since I enable logging again and check the log, I found there are a lot of records in “Configuration Changes” which all have the same contents related to avast.

I don’t like the popup, either. :wink: hope it will be fixed soon.

hey hfmouse, these configuration changes in the log as you state, could u place these logs in this topic here (bugreport, I made) → https://forums.comodo.com/bug-reports-cis/high-cpu-usage-comodo-v5-when-logging-enabled-in-conjuction-with-avast-v5-free-t62770.0.html

Cuz I think as well that somehow Avast 5 and CIS 5 are related whereas these CPU problems are concerned. So any extra info, and especially from multiple users, might help the team to try and find a fix for it. :wink:

I have this problem as well since updating to Comodo 5 two days ago. Never had a problem with v4. I’m using Win XP sp3 with Avast 4.8 Pro.

If there are any users out there still running v5 of CIS and Avast, please try something that was uttered in the bug report I filed about this.

Ofcourse state which version of Avast u have, and which version of Windows and post your findings in the topic of the bug report here → https://forums.comodo.com/empty-t62770.0.html

I don’t seem to have a CIS logging directory, not unless it is somewhere other than the install dir. I have tried making the whole CIS dir exempt in Avast’s On-Access scanner but that doesn’t help. BTW, I have only the firewall component installed, not the AV, and the cpu usage is 50% across both cores, not the 100% others are seeing (Athlon 64 x2 5200+ 2.7GHz).

I’m probably just going to uninstall CIS 5 now and go back to v4 until this is fixed :frowning:

Mlynn, yes the 50 % seems to be as well for me when my browser isn’t running.

however, some ppl seem to have fixed the problem.
Pls take a look here https://forums.comodo.com/bug-reports-cis/high-cpu-usage-comodo-v5-when-logging-enabled-in-conjuction-with-avast-v5-free-t62770.0.html

and see if that solution seems to work for you as well.