high cpu usage: cpf.exe

Hi, I have comodo firewall and avast home. I’ve never had problems since last weed when I started using bitcomet 0.84 for torrents. when I start bitcomet, cpf.exe use up to 70% of cpu for few seconds, then return to 0-1% for other few seconds and then again at 70%. It continues in this way, up and down, slowing my computer. What can I do? I set the “allow all activity for this application” option for bitcomet, but nothing has changed.

Hi and welcome, ziopaper.

It’s a logging issue. If you turn it off or set the C:\Documents and Settings\All Users\Application Data\Comodo\Personal Firewall\Logs\logs.log file to read-only it should be better.

Is it possible that I solved the problem disabling the “log events for application monitor” option?
If the answer is yes, can I disable the log only for a specific application instead of all ones?
thanks again

In current versions there is no way to log or not log at an application-specific level. (Only works for network rules). I usually notice that network rules have the most logs compared to the other monitors, especially for p2p because there will bound to be many blocked incoming connection alerts.

Greetings ziopaper!

It tries:
Auslogics Disk Defrag

thanks everybody for your attention, but:

  • my disk doesn’t need defragmentation
  • I tried to disable logging from the logs view in the activity panel, then I clear all the logs, and it starts again logging. The biggest problem are when using bitcomet or winamp, movies go slowly and cpf.exe takes a lot of cpu. I thought I had solved my problem, but I have not.

Did you right-click in the Logs window to disable network monitor? That seems to the one with the most alerts because of the large number of connections involved. If you would rather keep the log for just during the firewall’s active session, try setting the logs.log file to read-only per my above post.

ok, I’ve disabled everything, not only the network monitor, and yes, my logs.log is read only, but in the log panel, even after clearing the logs, a lot of activity is logged…I don’t know why.
bitcomet uses something like 50-60 tcp connections and in the connections panel it appears hundreds times. is there a way to tell comodo firewall to totally ignore an application? I disabled logging, but my cpu usage is still high
thanks again for your attenction

It’s normal for bitcomet or any p2p to have many tcp connections. If you open the connections window of course cpf.exe uses the cpu because it’s basically the GUI constantly updating. So don’t access the connections or log window.

If by totally ignoring an application you mean don’t log its activity, then there is no way. Only network monitor rules have the ability to log/not log, but they are global rules.

Are you sure that it’s cpf.exe causing the high usage after the logging is disabled?

ah, ok thanks. now, using only bitcomet, the cpu is normal, opening also winamp cpf.exe jumps at higher value of cpu, with peaks of 94%. in the task manager, I order the list by cpu usage and cpf.exe is often at the top with very high value. if this is the correct way to see wich process is using the cpu, then I am sure it is cpf.exe

That would be correct, Marco. Hmm…your case is a new one in terms of cpf.exe using cpu with logging off. The last resort I can think of is to register and submit a support ticket at http://support.comodo.com. (I submitted mine on other issues relating CFP high cpu usage). If you do, please link them to this thread for reference.

Using a p2p application is probably going to result in some CPU time, as CFP has to check and verify each packet coming through (since it is a Stateful Packet Inspection firewall), and as you say, there’s a ton of connections. This is probably not just related to logging, although by turning all that off, you should reduce the load quite a bit.

Also, if you file a ticket with Support, please let us know how it works out.


I have exactly this problem too.
Is there a solution?
CanberraThu 20-Sep-07 20:42

Welcome to the forum, BdH.


  1. Disable the log
  2. Beta test cfp 3

I too had the same problem with uTorrent. Disabling the logging and changing the log file to read only didn’t help, but I think I found atleast a temporary solution.

Task Manager → cpf.exe → End Process

Windows complains “can’t end process, access denied” but after doing that, cpu time used by cpf.exe went back to normal, now bouncing occassionally to max 20% instead of choking the whole computer. I also enabled the logging again, which didn’t seem to have any effect on performance.

It’s now been running about an hour after trying to end the process, and the cpu usage has stayed the same. I’ll report if the problem reoccurs and I can repeat the quick-and-dirty fix.

I might have the same problem. But why would it just start happening when I’ve been running Comodo and utorrent together for quite some time (months) and it didn’t happen before?

I did recently upgrade utorrent to 1.7.5 and I guess maybe Comodo has had an upgrade in that time, too. It is now at I see.

But regardless of all that as recently as a couple of days ago utorrent was downloading fine.

Last night it spent twelve hours downloading at something like .4kB.

I switched it off in disgust this morning and just happened to catch Comodo cpf.exe in the task manager running at 97% cpu.

Yes, I know, AFTER I’d switched off utorrent. But it was immediately after and I didn’t properly switch off utorrent, I just clicked the red cross.

It seems possible to me that it is some Comodo related problem I’ve got.

I’ll switch off Comodo entirely and test like that.

I’ve heard that if you’ve got a router you don’t need a firewall. What do you think about that? They probably mean that if you’re on a router there’s a network firewall installed by the network manager, I think.

I’ve got a router but there’s no firewall installed by any network manager because that’s me and it is just a home network with four computers all accessing the internet directly through a switch and into the router. Each computer has its own firewall installed. I think that’s a necessary step - would you agree?

Yes you need a firewall too.