High CPU usage Comodo v5 when used in conjuction with Avast v5 [283]

The bug/issue

  1. What you did:
  2. What actually happened or you actually saw:
  3. What you expected to happen or see:
  4. How you tried to fix it & what happened:
  5. Details (exact version) of any software involved with download link:
  6. Any other information you think may help us:

All these questions are best answered by copying/pasting what I mentioned before in another topic (includes screenshots)

Turns out more users are affected as well. See original topic here: https://forums.comodo.com/firewall-help-cis/high-cpu-usage-with-comodo-fw-v5-t62283.0.html;msg443220#new

Files appended

  1. Screenshots illustrating the bug: see above
  2. Screenshots of related event logs or the active processes list: see above
  3. A CIS config report or file: N/A
  4. Crash or freeze dump file: N/A

Your set-up

  1. CIS version, AV database version & configuration used: CIS 5 + Avast v5 Home Edition (free)
  2. Whether you imported a configuration, if so from what version: nope, clean install of CIS v5
  3. Defense+ and Sandbox OR Firewall security level: Defense+ at Clean PC + Firewall at Custom Mode
  4. OS version, service pack, no of bits, UAC setting, & account type: Win7 Ultimate 64bit, logged on as standard user. UAC set to Always notify me (and do not dim my desktop) when:
    Programs try to install software or make changes to my computer
    I make changes to Windows settings
  5. Other security and utility software running: nothing, other than Avast Anti-Virus
  6. Virtual machine used (Please do NOT use Virtual box): No

Thanks for you report

Please try these solutions here and report back on the results.

BTW you say other security software running = ‘nothing’, but I guess avast is - so please edit :slight_smile: Also please give your UAC setting account type details. (Just follow the red links in the format post if unsure what these are).

Best wishes


Just as a thought, what happens if you exempt the CIS logging directory from real time AV monitoring in a) CIS, b) avast?

Best wishes


Well yes ofcourse Avast, thought that was clear ;D I thought you meant any other security software besides Avast. I have editted it now. :wink:
Also I have stated my UAC settings now. My total Windows configuration/settings have NOT altered in any way after I updated from v4 to v5.

ust as a thought, what happens if you exempt the CIS logging directory from real time AV monitoring in a) CIS, b) avast?

I actually never tried this and I am back to running v4 for the moment as v5 gave too much problems.
Maybe other users that are affected and still run v5 could respond to this and try it out. I will quote you on this in the other topic with the request to post their findings in this topic.

Hi, I had the same issue…

I followed the topic “App. is not working correctly, […]” and point 5:

The program may require greater permissions that those held by trusted files, but be unable to ask for them. To get round this apply the installer updater predefined policy to all executable files in the program's directory, and any other executable files you know it uses, using Computer Security Policy ~ Defense Plus Rules ~Add. Remove the same files from trusted files, and any other entries for these files in the computer security policy ~ Defense plus rules. Then reboot. For security reasons do not do this for applications that you will use to run other unknown files.
did the trick for me. Redefining the policy for "C:\Program Files\Alwil Software\Avast5\AvastSvc.exe" is all it needs.


Unfortunately I have exactly the same problem on my side. I am using Avast Internet Security Pro but without the use of their Firewall. Actually I can not confirm that this “high cpu problem” is linked in any way with avast because on my notebook I have also installed both and there it works fine. The only difference between my desktop and my notebook is that I am using Windows XP Pro 32 bit on the Notebook and Win7 Pro 64bit on my desktop. Indeed this problem occurs first after the update to version 5. By the way in my case even disabling the logging of firewall or / and defense plus does not stop the cfp.exe process to use sometimes more than 60% of my two cpu cores so I also cannot confirm that the logging is the root cause to this problem. I am currently also thinking about downgrading to version 4 although I love this new design :slight_smile:

Best regards

Hi again :wink:

Sorry but I posted my last reply nearly at exact the same time as Birliban did and therefore I could not test his solution before posting :slight_smile:
I did the same now as Birliban and changed AvastSvc.exe’s policy to “Installer or Updater” in the Defense+ settings and now the issue seems to be gone…
@Birliban : Thanks a lot for this information.


Add me on the user having this problem.

Going to try to fix it and see if I can provide any solution.

We appear to have a solution to this but not one that makes a lot of sense (ie that is easily explicable) so I’m forwarding this as a verified issue.

If any of you manage to work out what is happening in detail, maybe by trying excluding logging directories etc please do say. (Please describe any experiment carefully).There is some evidence from other sources that enabling/disabling logging in CIS makes more difference than it should.

Best wishes


Mouse mate, how exactly does one exclude logging directories? Here’s what another user said in the first topic I started about this issue.

Apologies. Had to search myself.

  1. Here is the path: C:\Documents and Settings\All Users\Application Data\Comodo\Firewall Pro\cislogs.sdb

Exclude this file from:
AV ~ Scanner settings ~ Exclusions in CIS
& from equivalent in Avast

  1. Find the Avast logs (sorry don’t know where) and do the same in Avast and CIS.

Of course both should have already excluded their own files but… it has been know for them not to!

Many thanks for doing this

Best wishes


That’s for Windows XP I assume. Cuz a path like that does not exist in Windows 7. :wink:

Hmm, strange, cannot edit posts here.


the dir for Win7 (and probably Vista as well I suppose) is: C:\ProgramData\Comodo\Firewall Pro 8)

sigh an edit button would be nice here (don’t understand why I don’t see it now as I have editted posts here before)

Path to Avast logging is: C:\ProgramData\Alwil Software\Avast5\log

Sorry back in dark ages.

Re edits - know its a pain, but devs need a stable core bug report, and not all forum user can be relied on to keep the core subject stable, if allowed to edit. Soyou can edit in bugs board but not in verified issues.

If ever you really really need it to prevent miscomprehension just PM me or another mod, and we will edit.

Best wishes


Best wishes

Hi, I added the comodo log-file to the excluded items in Avast Files System Shield. That didn’t help though…

Another thing: the standard size for the log-file is 20 MB - I have set it to 200 MB now … and my log-file is now at a size of 97MB (without gaining anything )

Problem seems to have fresolved for me. I upgraded from v4 to v5 by saying yes to “there are updates available. Would you like to install them”
My firewall logging is normal now, also under the advanced logging I actually get to see the logs now, whereas before I didn’t.
CPU is normal. I excluded the Comodo log files in Avast real-time module.
I’ll still monitor it for a few days after which I will confirm if it’s really gone or not.
So far it looks promising though.

OK please do tell us. This suggests you had some bespoke settings for Avast in CIS 4.x?

I can confirm that the problem is gone. The only thing I changed (before upgrading) in my v4 configuration (I still had a backup of v4 when I did my first clean install of v5 when the problem occured) is that I excluded the comodo log file dir and after that I upgraded, which was possible now. When v5 was just released v4 didn’t say there was an upgrade available. So I removed v4, did a clean install of v5 and then I had the logging problems. Now, after deïnstalling v5 and reverting back to v4 I imported my config back and had no problems. So I decided to upgrade, but before that I made sure the logging was disabled from the Avast real-time scanner as a safety precaution becuz it was suggested here. So I cannot tell for sure if that was the culprit. Maybe it was the clean install of v5 that caused problems, even after I made sure I removed all registry entries with the .bat file after uninstalling v4. Too bad I cannot say with utmost certainty what it was that caused the problem. I am just glad everything is back to normal again now when running v5.

For what do you need Avast, when using Comodo Internet Security? Comodo has firewall, virus an spy protection…dont get it…

AND, Comodo software is completely 64bit! Avast is not!