Hidden VTRoot folder and chaos installing software.

Hi, it’s been a long while since i visited this place, because Comodo Firewall has been solid and trouble free, until recently. I’m currently using version of the free firewall.

Anytime i am not online (which is most of the time with the PC in question) i have the firewall in ‘game mode’ as i’m either working on that PC or playing games.

I’ve been having a huge problem when installing new programs on the PC, stuff would seem to install, but then not be where it should be (as in no icons on desktop/missing stuff in the installation path etc), and i was getting no notification that anything was wrong.

Anyway after much head scratching and re-installing over the last few weeks i discovered the hidden VTRoot folder in the C:\ directory and most of ‘parts’ of the various software i had been using was here distributed between the HarddiskVolume2/3/4 and 5 folders.

In one might be the save games from a game, in another the activation and un-install icon of a utility program etc. And i’m pretty certain this has been the root of my PC’s issues for a little while now.

So i’m posting this in case others have been seeing ‘odd’ behaviour of their programs they have tried to install while having Comodo Firewall running (but in game(silent) mode). Also maybe the Comodo devs can think about maybe a better way for the user to be informed of this effect and where (and what!) VTRoot folder is and how to best use it to avoid broken software and lots of confusion and frustration (i nearly was at the point of doing a complete Windows re-install, and had gone through a battery of anti-malware and virus scanning tests!).

I might just have been using the Firewall badly here, but some note in the GUI to that effect would have gone a long way :slight_smile:

In later versions of CIS, the auto-sandbox is set to Fully Virtualized by default, this means that all unknown programs will be launched in a fully virtualized environment, and this data is kept in C:\VTRoot\

I’m not sure if applications are auto-sandboxed if CIS is in Game Mode, but Game Mode does disable most if not all notifications as well as make pretty much all defenses inactive, I would suggest not using Game mode but that may not be an option for you, just a suggestion though.

Ah annoying.

I’ve also discovered shutting down the Firewall completely (as in right click on icon in taskbar and select ‘exit’>agree to prompt) does not solve the issue of it running the virtual sandbox thing in the background. So yet again i’ve had issues trying to install things. How long has it been doing this, as i used to have no problems with it at all? It seems a ‘recent’ thing?

The answer might be to manually shutdown the firewall and then go through Windows Task Manager to shutdown all the Comodo Services? ‘Comodo Virtual Service Manager’ looking the most likely culprit?

Or is it best to keep the Firewall fully on when installing software, although i had read this was not best practice and most software suggests you turn firewalls off when installing etc.

Or maybe Comodo could include a mode for installation of other programs that does not place it in VTRoot?

Shutting CIS down in the way you mention is simply shutting down the GUI, not the background workings of CIS.

I can’t remember if Fully Virtualized by default was introduced in v7 or v8, one of them.

You shouldn’t turn off the firewall at all to be honest, if you’re not in game mode then it should show a notification in which you can choose “Do not sandbox this program again” (or similar) then next time you run the application it will run outside the sandbox (unless it’s installed in the sandbox)

CIS also has an option to detect installers, if an installer is detected then you will get the option to run it unlimited directly.

You should always have the firewall turned on. Software that suggest you turn off your firewall is dodgy and frankly insane, suggestion the creation of exclusions I can accept, suggesting to turn off completely? Pure insanity. Why even have security solutions if you’re going to disable them when installing things etc? That doesn’t seem quite logical to me.

In any case you can disable the Auto-Sandbox by right-clicking the taskbar icon and clicking Auto-Sandbox > Disabled then run the installer.

I’m not going to argue about the ‘don’t install with running programs in the background’ thing that nearly all software recommends, as i’ve always found that stupid too, but this auto-sandbox thing was causing me problems, application and game breaking problems when used in the ‘game mode’ setting.

But we live and learn and thanks to your advice i have now switched auto-sandboxing to off when installing software and that seems to have solved the problem. Thank you very much for your advice, a nice obvious and simple solution :slight_smile: