in the task bar the clocks time and date keeps changing. in control panel i clicked on date and time setting and fixed it. for 2-3 days its ok and then i find it changed again. the problem is from 20 days. sometimes avast also pop ups and says avast cant update coz your computers time and date has changed so your registration key has been disabled. fix it and enter the licence key again. what can be the problem? help guyz

Are you sure that your on the right day and year? Right click on your task bar right over the clock and bring up the Adjust Time/Date. Also did you recently have a power failure or surge? Is your clock set properly in your bios?

If this happens after you turn off your pc it’s either a cmos memory corruption or a failing Motherboard backup battery.

yes it happens afer i turn off the pc. when i start the pc sometimes a message pop ups like press f1 to continue and f2 to set up ---------- (something i dont remember) if the set up is related to date and time settings should i press f2



Yes you need to go into your bios and check that your clock is set correctly there. It will be in 24 hour time.

Then I guess changing the backup battery comes first (How To Install A CMOS Battery)

If a new backup battery doesn’t solve the issue it is a CMOS memory corruption issue (faulty motherboard)

ok. next time the pop up arrives i will do so and check if the problem is solved and let you guyz know

The pop has nothing to do with it. You need to boot up into your bios and check your time there.

It’s an internal problem.

You do need to boot into your BIOS settings as V said.

i have winxp sp3 installed. how to get into bios??

When you boot up hit F12 or sometime tab. You said it tells you to hit F2. Try that.

when i should hit any tab?? after entering windows password or prior to that. also should i keep the tab pressed or keep on pressing-leaving till the bios arrives

Your bios is your motherboard set up. Has nothing to do with Windows itself. When you first boot up your pc you need to go into your bios which is a blue set up screen. Are you able to get there?

i went into bios

under system - system info - bios version - A03 01/01/2006

                  time and date setting is proper sat 19 2008 7.48pm (i m frm india)

Well aslong as the date and time is completely accurate in the bios then that is covered.

So are you still having the issue?


from past 2-3 days everything’s fine. lets see…

thanxx guyz

it again changed today. what can be the problem??

Possible your bios battery is weak. So what your saying is your Windows clock is out of sync and not showing the proper time or day? You can try replacing your battery on your mother board.

when i open the time and date settings there are 3 tabs. i read in a forum that under 3rd tab i.e internet time automatically sync should be disabled, is it correct?? also when i go into bios settings and try to unlock the settings to make necessary changes it asks for admin password. i haven’t set any admin password. is there any default password from microsoft. my windows copy is genuine. if there is any default password what is it?? i tried using windows logon password but failed.