help with stubborn CTM uninstall


Tried to install comodo time machine but something went wrong and now no matter how many times I try to uninstall it using comodo uninstaller in tells me to restart and then an error message of comodo time machine failing to uninstall. I have done this many many time and in safe mode as well and still the same. I tried removing using revo and iobit uninstaller and manually cleaned all comodo files and nothing left on pc and even reg cleaned with many reg cleaners and manusl deleting of registry of anything comodo related. But when I try to reintall i get the remove message from comodo time machine installer. I can not find any sign of comodo in my pc but the installer gives me removal option. I am dumpfied. IS there a removal tool for searching for any hidden comodo files on my machine? If I can not get a complete cleaning of my machine then I will stay away from comodo products since they are very stubborn to get rid off when uninstalling. Any help is appreciate it.

Hi taleblou:
Please restart computer, press “HOME” key when you see the CTM Subsystem Console screen, and then uninstall CTM. If you can not see the CTM Subsystem Console screen during bootup, please give me your email, i will send a fix tool for you.
Thanks for your feedback.

Best Regards.


As I said there is no sign of any comodo files on my system. Just like its never been there but the message still appears during installing comodo and when scanning I still see remnant of CTM that must be hidden somewhere on the pc that no win search or cleaning tool can find it. Please send me a full cleaning tool . My pc has windows 7 home premium and currently no comodo programs installed except traces or hidden files I guess. My e-mail is Thanks in advance. Please include tools for removing all traces of CTM and also of any other comodo related from my system.


Thanks for the tool. It removed a file and then CTM was able to go through its uninstall. After uninstalling CTM and cleaning, I tried to install CTM but after reboot I got the same CTM critical error message which said: “A critical subsystem required for the proper functioning of the product is not active. This usually happens with an incomplete installation. Please re-install the product and try again.” Just like before everything started over again and CTM got stuck. So had to use the tool again so I could uninstall CTM again and clean my pc. I do not know why CTM I downloaded from the download page on comodo does not install correctly on my pc and causes errors and issues. So I have given up on CTM. Thanks for all your helps.


I was told that MBRguard could be the culprit of the CTM install problem. Well my question is does CTM protect MBR or not? I need to know to use MBRguard after successful installing of CTM or not? Thanks in advance for your reply.

Right now. No.
If you use an antivirus/security suite you’ll probably be covered.

MBRguard simply blocks without prompting end-users. There is no GUI and it provides no alerts
I think if you have it installed before CTM, CTM won't be installed. If you install it later, CTM won't be uninstalled. In both situations you can lose data and booting capabilities...


Thanks for the reply. I have one more question to ask. Does comodo internet security premium (CIS 5) protect MBR or not? If I tried to uninstall MBRguard will CIS 5 keep me safe from MBR infection or not? If not then can you suggest one that does. Thanks in advance.

Well it protects from raw disk access and driver installation, so I guess yes, it protects mbr

No, it does not protect against MBR infection.
A good antivirus or suite will do it. Do you use CIS?


Yes I do use it right now because of its lightness, but was wondering do you know of any free antivirus or suit that does protect the MBR? Thanks in advance. If there are not any then I guess I stay away from CTM, since MBR protection and TDSS protection are important for me. By the way does CTM snaphot includes MBR snapshot just incase to restore or not?

CIS could protect you. avast, Avira, AVG… can protect you.

No, it does not include the MBR into the snapshots.