Help with sharing using Comodo firewall instead of windows firewall

I am using the latest comodo firewall have been some time, I using homegroup to share to my computers and tv on my network but, service won’t seem to work without window firewall turn on, I attempted to share my printer and got a error until I turn on the windows firewall, HomeGroupListener service won’t run without it on. Here is a link about the printer, Error 0x000006D9 when you share a printer - Windows Server | Microsoft Learn, what is the setting that I need to make in comodo to take care all this? thanks for any reply. don’t want to have to change.

You need to make your home network a trusted network.

First step is to define your local network under Network Zones. Give an appropriate name. Assuming your LAN is in the 192.168.1 range you can define it as an IP address with network mask:

Once the local network has been defined run the Stealth Ports Wizard and choose the first option “Define a new trusted network and make my ports stealth for everyone else”.


EricJH, I tried your suggestion but it didn’t work, thanks

You posted about this back in January. As I mentioned then, you don’t need to have the Windows firewall enabled, for Homegroups to function correctly. Did you create the rules I indicated?

Yes I did create the rule, but HomeGroup Listener will not start without enabling windows firewall, thanks

Have you enabled IPv6 filtering in the firewall - Firewall Behaviour Settings\Enable Ipv6 Filtering

[attachment deleted by admin]

Yes, I have enable IPv6 filtering, I just decided to use windows firewall 7, instead of the headaches of trying to get this working, thanks for all the help