Help with firewall

Hello -
this is my second time giving comodo a try.

I downloaded the lates version and installed with no problem
(_3.5.57173.439_XP_Vista_x32)

seems like every thing works unitl I try to connect to the internet.
No browser is able to (IE,Firefox, Opera, Flock, Safari)
I went and configered the trusted applications (web browser, windows apps)
still not able to connect.
I configered trusted zones:
IP In [127.0.0.1 / 255.0.0]

local area network #1 [169.254.65.136 /255.255.0.0]

I tried restarting the computer, disabling the firewall, turning off windows firewall, adding comodo to windows firewall, unplugging the cable modem for 30 seconds.
I also uninstalled and came back to the forum here and tried to find other info I might try.
My internet works when I completely uninstall comodo and restart - otherwise no internet.
I also uninstalled avg free virus protection and installed comodo antivirus - to no avail

finally I started the computer in safe mode with networking support -
Only after I unchecked the comodo firewall driver from the “local area connection” properties window
was I able to connect.

My network card is:
Realtek RTL8168B/8111B Family PCI-E Gigabit Ethernet NIC (NDIS 6.0)

do you have any suggestion on how I can use comodo? or fix this issue?

thanks in advance.

Hello Peacepole1,

Based on your local network 169.254.x.y i would say that CIS Firewall blocks DHCP requests, this ip range is used by Microsoft if there is no “other” ip address given to the computer by some network device (normally the router).

Did you run “Stealth Wizard” ?

Can you check the firewall log and see if it logs anything about udp traffic on port 67/68 ?

You could try to boot your system with firewall disabled, after startup you’ll receive an ip address from the router.

I ran stealth wizard a couple of times -
1 where I would like to define my trusted zone
where I picked the Local Area Connection #1 that was showing in the drop down box
2. Block All

Either did not result in being able to access the internet

and the udp on all = 0 in 0 out

with this issue I can only access internet when I uninstalll comodo completely or
uncheck the comodo firewall driver from the network property’s box
when I re-check that box the computer see a network that it can’t identify
when I use the windows repair the connection wizard I see a yellow triangle between my computer and the “unidentified network” and a red x between the network and the internet.

Can you check this post and create the suggested rules in the global rules tab ?
Now reboot and see if that helps.

For the disabling of the firewall, if you have the white shield tray icon, right click go to Firewall Security Level and set it to disabled, this should make you able to reboot and receive an address from a DHCP server…

Hey Ronny
thanks for the help
I set the global rule as stated and disabled the firewall
rebooted - nothing changed
also the only way I can access internet still is to uncheck the firewall from the network properties.

not sure what to do next?

We first need to make sure your able to get connection everytime.

Can you open a command box and type ipconfig /all ?
If you don’t like to post it here you can send it to me in a PM (Personal Message) on this board, just click my name and chose “Send Personal Message”.

ok I did ipconfig /all

With firewall checked

connection -specificdns - nyc.rr.com
description Realtek RTL8168B/811B
Physical address = 00-13-8F-D2-47-4D
DHCP enaled - Yes
Autoconfiguration enabled - Yes
IPv4 Address - 74.73.14.126
Subnet Mask - 255.255.248.0
default gateway - 74.73.0.1
DHCP Server - 10.37.160.1
DNS Servers - 24.29.103.15
24.29.103.16
NetBIOS over tcip - Enabled

With firewall

connection - specific dns -
description - Realtek RTL8168B/811B
Physical address = 00-13-8F-D2-47-4D
DHCP enaled - Yes
Autoconfiguration enabled - Yes
Autoconfiguratio IPv4 Address - 169.254.33.235
Subnet Mask - 255.255.0.0
default gateway - 0.0.0.0
DHCP Server - 10.37.160.1
NetBIOS over tcip - Enabled

Okay now we need to check the application rules, can you please check and see if you have any block rules on any system, windows operating system, c:\windows\system32\svchost.exe rule ?

It looks like the global rules are matched but the application rules could still be blocking something.

Maybe you could post screenshots of the global rules and of the above mentioned rules ?

The Firewall is definitely interfering the DHCP process.

Wait you say you rebooted with Firewall disabled and it still does not work ?
Can you set Defense+ also to disabled and reboot ?

And can you check your Firewall, Advanced, Attack Detection settings, and Misc also did you change anything there ?

Hey Ronny
Apologies for the long delay in getting back to you -
I went ahead and did a fresh install vista -
there were a couple of other factors I was thinking about
and it occurred to me that most others I’ve seen post installed comodo and it worked out of the box -
so I thought I would give it a try with a fresh install of windows and comodo
and it does.
works fine so far (only been a day)

so I’m going to run it for a while - and see what happens.

Much thanks for your speedy replies and willingness to help figure this thing out!
:■■■■

Okay no problem, good to see you got it fixed !
I hope an other happy member of the Comodo Free Security suite :slight_smile: