Help with Dlink 320 Media Server [Resolved]

Hello

I am new to Comodo firewall and so far I am very pleased with it. Having one small problem though. I have a D-Link 320 RD media server which I use to stream media. My computer is set up with a Linksys wireless router and a local network is established. The D link sees the network just fine, However when I attempt to stream files Comodo blocks the traffic. I figure I simply need to establish a new rule to give permission for the Dlink to communicate, but I am really a novice at Firewalls and so far my attempts have failed miserably. Below is a copy of my log showing the block. Any help is greatly appreciated. Thanks

Date/Time :2007-05-08 17:02:32
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = 192.168.1.100, Port = upnp-mcast(1900))
Protocol: UDP Incoming
Source: 192.168.1.100:58756
Destination: 239.255.255.250:upnp-mcast(1900)
Reason: Network Control Rule ID = 5

Jake

First to check if it’s a rule problem, turn off Network Monitor and see if it works or not. You might have to restart everything to get the changes to take hold.

Security>Network Monitor>Turn Off–at the top of the rules list window

If it works after doing the above then turn it back on and write the below rule for starters:

ALLOW–check the checkbox
UDP
IN
Source IP: 192.168.1.100
Destination IP: 239.255.255.250
Source Port: ANY–try this first then if it uses the same port everytime you can change it
Destination Port: 1900

If this rule doesn’t help then post your log so we can get a look at it.

VERY IMPORTANT: Also put the rule above all block rules in the rules list.

jasper

Thanks Jasper

Tried turning off Network Monitor and was able to access the media server with no probs. Then I implemented the rule you suggested—made it rule #5 right before the block rule. Unfortunately no luck. Here is a copy of the log [attached].

Sorry for the large size…just wasnt sure what you might need to see. Thanks for your help on this…really appreciate you taking the time.

Jake

~Edited by mod to replace log with text file attachment to shorten post length~

[attachment deleted by admin]

Ok, I am assuming that you have the media server setup to get it’s IP from the DHCP server in your router and that the IP of the media server is 192.168.1.100.

Try changing the rule to:

ALLOW–check the checkbox
TCP
IN
Source IP: 192.168.1.100
Destination IP: ANY
Source Port: ANY
Destination Port: ANY

You might need to restart the system again for the rule to refresh correctly.

jasper

You are correct…that is how it is configured. Tried the new rule…worked for a second or two then it blocked traffic again. Here is the latest.

Have a feeling we almost have it. Thanks again

Jake

~Edited by mod to replace log with text file attachment to shorten post length~

[attachment deleted by admin]

Ok, change the rule to what I have below and it should work. I went to the D-Link site to read the manual to see how it works while you were trying the last rule.

Let’s modify the rule again:

ALLOW–check the checkbox
IP
IN/OUT
Source IP: 192.168.1.100
Destination IP: ANY
IP Details: ANY

What you are doing here is allowing every type of communication between the server and your PC. Hopefully you will be a happy camper after this rule. ;D

jasper

The rule’s not going to work because the IP address keeps changing. But here’s a couple things you might try.

First, just create a Network rule (above block rule):

Action: Allow
Protocol: IP
Direction: Out
Source: Any
Destination: Any
Details: IGMP

Reboot and see if that helps.

If not, remove it and edit Jasper’s rule to read:

Action: Allow
Protocol: UDP
Direction: In
Source IP: 192.168.1.1
Destination IP: Any
Source Port: Any
Destination Port: 1900

Then Add another rule right next to that one:
Action: Allow
Protocol: UDP
Direction: In
Source IP: 192.168.1.100
Destination IP: Any
Source Port: Any
Destination Port: 1900

Reboot.

See if that helps. I’m thinking the simple addition of the IGMP rule may help; being an Out rule, the In response will be automatically allowed. If IGMP is allowed (which it’s not by default), then the system may not resort to using UDP.

LM

Worked like a charm! jasper much obliged. Thanks for the time and effort

Jake

Sorry to run you thru all the hoops, Jellycat, but I was trying to find out exactly what ports and protocols that it was using. You were the guinea pig on this one.

Enjoy! ;D

jasper

Good research Jasper; your reply slipped in right as I was posting but I just posted and kept on moving… ;D Should’ve stopped and read it…

Glad that’s working, Jellycat. The topic will be marked as resolved for other users’ benefit and closed. Should you need it reopened, just PM a Moderator (please include a link) and we’ll be happy to do so.

LM

FYI: I replaced the lengthy log posts with text file attachments.

UDM, Soya! (:CLP)