help with adobe acrobat download

I cannot download the latest adobe acrobat reader.
Here is the site:

When I try to download, I get a message:
Attack Detected
Application Mozilla Corp
Comodo Safe Surf blocked this application from executing a possible buffer overflow attack.

I disabled the firewall, and still get the message.
This has to be a false warning, right?

XP SP3

[attachment deleted by admin]

Yes. It’s a false warning.

This thread has some options that might help:
https://forums.comodo.com/empty-t25597.0.html

:slight_smile:

FaZio93,
Thanks for the pointer.
I exited Comodo, and disabled cssurf.exe and cfp.exe in startup and rebooted.
No help.
I finally rebooted to safe mode and got it.
I would have tried disabling CSS from the Comodo panel, but my panel only
shows: Firewall and Defense+.
From my log, it looks like I installed CFP V3 on 2/23/08.
Since then I have let it do an auto update.
So it is working ok, but I cannot control CSS.
I am not sure if I should go to safe mode and uninstall and then reinstall with the latest download file or
update install with the download file.

[attachment deleted by admin]

Oops, I spoke too soon.
When I try to install AdbeRdr90.exe, I get this error:
Error 1402 Could not open key:
HLM/Software/Classes/AcroExch.Document

In regedit there is a shell/Open key.
Does the Open key lock the AcroExch.Document key?

Maybe I should go back to safe mode and install it from there?
Or is there a way to fix this from the Comodo panel?

[attachment deleted by admin]