Help w/slow browsing... Been 4 days... Possibly solved!

I’ve read through the faqs and other posts but have not found a solution for this problem. Having read good reviews on this product, I decided to give a test and compare it with ZoneAlarm. I installed Firewall Pro v3.0.25.378 on my system running Vista Home Premium 32bit (SP1) with avast! Pro v4.8, SuperAntiSpyware v4.21 free, MBAM v1.30, and Secunia PSI v0.9.0.5 already installed.

I had Windows Firewall running prior to this installation without any issues when browsing the web with Firefox v3.0.3 and IE v7.0.6001. I installed CFP3 v3.0.25.378 without problems but discovered my browsing was extremely slow if at all (page load error - network timeout error at, for example). I’ve tried numerous things thinking it was related to my security tools/browser not playing well together - or needing some additional configuration. After several hours of various tests, it appears that it is specifically related to CFP3 and/or its setup. If I turn off the firewall and leave everything else as is, my normal surfing speed returns. Turn it back on and it’s very slow or results in a timeout. I uninstalled it, restarted Windows Firewall, and browsing was back to normal. I then turned off Windows Firewall and reinstalled Comodo again (UAC off, run as administrator) with the same slow results.

Lastly, I tried tweaking a few CF3 settings to no avail. I had the Firewall Setting Behavior configured with the “this computer is an internet connection gateway” setting originally on (presumably because I answered I share files/folders), then off with no affect. I also tried rebuilding the Firefox application rules using the WebBrowser template with no success.

As a side note, the one thing I originally thought was a discussion about needing to set up proxy setting for IE to work properly with avast! Webshield, but that is only for 98/ME (and trying it just in case didn’t help). If curious, the link is:

What do I need to do to make this a workable solution for myself (and others)? Thanks in advance.

Also, I did not choose the SafeSurf toolbar or search options during the installations…

One added note - I had given up testing using because it just sat there after choosing a test server. In letting it go for a minute or so, it provided the following results:
Download: 13386 Upload: 77

The download results are in the ballpark, but my typical upload is extremely low. In setting the Firewall Security Level from Safe Mode to Disabled and rerunning, I get:
Download: 13835 Upload: 3272

Then resetting it back to Safe Mode:
Download: 14079 Upload: 81

Also notice the ping is terrible - 999 on the last run!

I was and still am curious after reading more posts about upgrading to v3.5. I originally installed CFP3 and was told there was an update. The details box for the update was empty except for a yellow triangle with an exclamation mark. I chose to do it and started getting the cfp.dll errors others have encountered (unable to run or uninstall CFP3). I ended up going back to an image I’d made prior to the install as system restore ran into an error.

From what I’m reading on the website, v3.5 is an upgrade to the full Internet Security package and not an upgrade for the firewall, right? I already have avast! and only want the firewall functionality, so this time I chose not to upgrade. Assuming this is the case, if an upgrade were to come out solely for CFP3, how do I request that one without getting the other?

This is a side issue, my main concern is why the slow down occurs after installing CFP3. Any ideas - I really want to get this working having read a lot of positives about CFP3…

Further testing - I went back to an image I’d made containing a fresh Vista install with only the drivers installed. No software or Microsoft updates were installed. I installed CFP3 and tested browsing with IE7 and had the exact same results. The only thing I noticed was running the speed test was very slow in ping (and upload) time as seen before, but running a ping from the command prompt was fine. The ping from the command prompt shouldn’t bypass the firewall, yet… I’m stumped and can’t spend any more time on this - is there any one with any suggestions??? Seems I’m the only one responding to this post :frowning:

Any assistance or responses would be greatly appreciated! Again, on a bare bones installation (drivers and no other software installed except for Comodo) had the same problem. As soon as I disabled the firewall component, the speed returned to normal (it was instantaneous).

I do have my laptop set up for dual booting with WinXP installed on another partition (though have yet to do anything with WinXP) - could that have any affect?? Sure hate to go back and do a fresh install of Vista alone just to test this out!

Please, any moderators out there that can give me any ideas of what to check out?

You should not be having problems.
Have you got IE7 set as a web browser Predefined Firewall Policy, are you running a proxy, what mode is your firewall in.
You could try delete your IE7 rules and let it learn them again.
EDIT Have you tried stopping Webshield in Avast if this clears the problem it means the firewall is blocking internet access for Webshield

First of all, I’m sorry that you slipped through the nets…

But honestly, I have no idea what’s going on. Try Dennis2’s idea, if that aint working try one of these

Try CIS, on installation uncheck the antivirus part if you want to continue using Avast. I also sujest you take another browser, Opera for example.

Again, I have not really an idea what’s going on but could you post back a Hijackthis log ? And perhaps run Superantispyware and Malwarebytes antimalware just to make sure that your computer is clean

I hope some of these things can shed a light on this


I am not a computer expert, but I suggest you to install CIS. The firewall you are using now contains some bugs that gives trouble in certain circumstances…

I know you already have an anti virus solution installed on your system and you have faced many problems, but do try the upgrade and see if your problem still persists.

  • uninstall the cfp firewall you are using now first, using an uninstall program like revouninstaller. and reboot your machine
  • install comodo registry cleaner and shutdown all running applications, including applications running in the background and the taskbar icon field.
  • run the CRC and run a temo file cleaner like ccleaner.
  • download and install comodo internet security, do not worry, this suite is customizable =.
  • when starting the installer of cis, you get the option to install only the firewall part! so uncheck the virus option and just install the firewall part. (later you can install he av part, just starting the installer again!, very handy…)
  • reboot your machine and let me know if you still have low internet speed.

have a nice day.

Lol, you asked for aid, now you got it :slight_smile: :wink: :-TU

Could you please post which method worked (if any)



No problem - glad to get some ideas! I figured this would be a tough one…

I’ll give these a try again though I’ve gone through most of the suggestions already. Going from memory:

I had done a full scan with avast!, MBAM, and SUPERAntiSpyware and all came up clean.

I originally was using Firefox 3.0.3 and tried with IE 7 just to see if it was browser related. The connection setting for Firefox is no proxy (and tried auto detect), IE originally had nothing chosen in LAN settings (also tried auto detect here).

In CFP3, the Firewall setting was Clean Mode. I was using the rule(s) it had set up for Firefox originally. I then tried changing it to WebBrowser which added some rules but still didn’t help. I didn’t remove Firefox first - will give that a try and let it relearn (and then try WebBrowser again).

I did the CIS3.5 install without the AV component but no go there either.

Finally, I did a fresh install of Vista loading only manufacturer drivers. I installed CFP3 before connecting to the internet, and then connected and tested with IE7. There should not have been any malware concerns given the source of what was installed.

Ok, at this point I’m running my image with Firefox, my malware protection (MBAM, SUPERAntiSpyware, and avast!) and just using the Windows firewall (I know!). I have some additional software installed that has been scanned numerous times. I’ll run the scans, install CIS3.5 without the av component, and set both browsers to have WebBrowser rules and let you know. If I post a hijackthis log, should I just paste it into a reply here?

Also, just in case - my overall setup involves running this system wireless (and tried wired) to my router (cable modem connected to the router). It’s been in place for a long while without any other issues…

Thanks again and will follow up with my tests!

Well, if all fails. I think it’s the best you try the 2.4 version.


And way cool - waited patiently but figured had to finally be the “squeaky wheel” Thanks for all the suggestions and will give all a try. And Fake vegeta, the image I currently have is pre Comodo so there shouldn’t be any remnants, but will still run the Comodo registry cleaner and CCleaner first.

And last resort, will give 2.4 a try… I likely won’t have a lot of time to work on this until Monday, but will post all I find as soon as I get results.

Again thanks all! (:HUG)

A bit of delay in getting back to testing, but gave all suggestions a try without success :frowning:

I scanned my system with avast!, MBAM, and SUPERAntiSpyware and it came up clean. I then installed CIS v3.5 Firewall with Maximum Proactive Defense+ (without the AV component). The firewall is set to Safe mode and Defense+ is disabled. I then tried three separate browsers (IE7, Firefox v3.0.3, and Opera v9.6) and found all to have the same very slow browsing issue. I uninstalled Firefox and reinstalled it, removed the firewall entries and let it relearn, removed SuperAntiSpyware - all to no avail. And I couldn’t try v2.4 because it couldn’t install on Vista. Just not sure what else to try…it’s just plain odd that Windows Firewall and ZoneAlarm work fine yet CIS v3.5 doesn’t.

I tried testing this on my other system running WinXP SP2 with essentially the same software and it worked fine. What’s odd is I did a clean install of Vista and didn’t do any real tweaking or special configuring. When I test speeds using the browser (using, the ping and upload are terribly slow (essentially a timeout on the ping, and upload is at about 5-10% the normal speed). Yet no issues when I ping from the command line. Maybe going down the wrong road, but…

Having spend a good bit of time, I’m about ready to shelve this at least for the moment unless someone has any solid ideas. Thanks again!

Maybe this is not a firewall related issue, maybe it is just network related… I mean local area network related… vista can be a pain in the… when surfing through a lan, and the acces point also should be at least compatible with vista. try to check you only surf through IP version 4 and uncheck IP version 6, set also in your accespoint the IP version 4 option… maybe this will solve your problem…

I do not know if the above suggested is something that has to do with your problem, but if you have not tried it, maybe you should.

ok, have a nice day,


Thanks for the suggestion Fake vegeta and agreed - Vista definitely is a pain at times! I’d done some reading and testing in regards to the networking and tried turning off IPv6 without luck. I went back again after reading your post and it finally hit me - Comodo adds the “Comodo Firewall Driver” networking component. I unchecked it and my browsing speed went back to normal. ;D

This raises the million dollar question - what does the Comodo Firewall Driver component do? Is it vital for maintaining firewall security or will Comodo function fully without it? So…if it isn’t required, it appears I’m good to go. Otherwise I’m still stuck, but at least have it narrowed it down.

So, need to hear from someone in the know - is Comodo’s functionality affected by running without this network driver?

A secondary question that likely will be difficult to answer/pinpoint is why does it appear to be causing a problem only on my system? In going back and testing, my Vista install was a “generic” install without modifications or tweaks and only Comodo installed to verify the conflict wasn’t with another 3rd party package.

Thanks all!!

I am no computer expert, your questions can be at best be answered by the developers of this firewall… try to contact them through one of the online moderators…

I do have an idea, why this affected your system… I do not know what kind of network adapter and drivers you are using, but it is possible that your network adapter drivers are conflicting with the “virtual” comodo network driver… It is possible that this conflict only is affecting certain network adapter drivers and in certain circumstances that might be not be reproduced during the developing of this firewall by the firewall devs… But I am no developer, only a volunteer, so only the developers know it for sure…

I hope this helped you, I wish you a nice day!


try to contact them through one of the online moderators....
Please don't ! Pm them yourself, we don't know them either. We're volenteers like you. I can only tell you that you need to pm Melih for that :)


Thanks and your answer makes a good deal of sense. After all the testing, it certainly pointed to something specific to Comodo and my system not playing well together… I will PM Melih and get more definitive info. Thanks for all the help and have to say I’m definitely impressed with the forums and assistance!